PDA

View Full Version : [Question] Animated Pokemon in Older Essentials Versions


tylerab01
May 28th, 2012, 11:27 AM
I noticed that in newer versions in Essentials, game creators can use Animated Pokemon. I am using Essentials 08 because that is what was available when I started game development in 08. How would 08 users add animated Pokemon??

Nickalooose
May 28th, 2012, 12:24 PM
I suggest upgrading, if you have your own scripts, just re-add them to the new Essentials, other than that, any scripts that you have, may probably not work if you just add the animation thing to yours, I may be wrong, FL . or Maruno will probably be able to answer this more thoroughly though

Maruno
May 28th, 2012, 01:00 PM
I know nothing about animated Pokémon sprites. I thought I should just say that.

Riansky
May 28th, 2012, 01:12 PM
You mean the ones like in B/W ? If so, those are just gif images. I don't know if 08 version of Essentials can use gifs but I think it can. But I would really suggest you upgrading to newest version.

tylerab01
May 28th, 2012, 06:19 PM
Thanks for the Input. I will try to update if I can.

FL
May 29th, 2012, 04:07 AM
I know nothing about animated Pokémon sprites. I thought I should just say that.Me too.

I tooka quick look and fond that the current version can detect sprites when the sprite is ".gif" and animate it (search for ".gif" and "class GifBitmap").

Your version probably don't have this class, there two fix:
1-You can paste this class with adaptations to work with a old Essentials version. This require a good script knowledge.
2-You can update your version. You probably need to spend a huge time to adapt the PBS, the scripts and the scripts in events in your game to the newer version. With this you can use several new features as well.

tylerab01
May 29th, 2012, 06:32 AM
I do not have very many scripts done, but I should be able to adapt my Trainer Card and Dual Screen with ease.