PDA

View Full Version : Vba - God Awful Slow!


dstaley
April 9th, 2007, 11:29 AM
Sometimes while running a GBA game in VisualBoy Advance, it gets horridly slow, like, 60% slower. This seems to be totally random, and I can't think of anything that would contribute to it. I have a GREAT pc, Dual Core AMD 64 1.6Ghz, 1GB Ram.

YourNobody
April 11th, 2007, 06:02 PM
You must have an amazingly slow computer, but there is the throttle. You can use the throttle to dictate the percentage you want to maintain.

You can find the throttle under "Options" and then "Frame skip."

Also, make sure your "Priority" is set to "Highest."

Tip: If you want to go around 100%, type 105% under the "Custom" option.

WARNING: Using the throttle increases frame skip, but increases performance.

linkinpark187
April 13th, 2007, 06:14 AM
do you have any filters on? if so, turn them off. i have an AMD Athlon 2500+ 1.8 ghz with 512 mgs of ram and a nVidia GeForce FX 5500 256mg video card, and VBA works perfect fine for me. if you need help with anything else on VBA or any other emulators, just let me know.

PikachuMan
April 20th, 2007, 06:54 PM
I'm not sure a lot of people have the same problem as you do.
I don't and I don't have all that fancy stuff in my CPU.
I just have the same old GateWay. Not very fancy. I don't know about the memory in my stuff, so I can't tell you what I have to see if we have differences. Sorry.

Skeetendo, Inc.
April 21st, 2007, 01:53 PM
I've had this problem, did you download the version 1.8.0 beta 3? If so download Version 1.7.2 (The latest before the beta) because I've experienced slowdowns with the 1.8.0 beta 3 tons of times..

YourNobody
May 2nd, 2007, 11:47 AM
And if that doesn't work, I recommend getting VBALink (http://www.vbalink.info) or NO$GBA (http://nocash.emubase.de/gba.htm). Both of these emulators are much faster than the normal VisualBoyAdvance emulator.

jonicito
May 8th, 2007, 03:35 PM
vba 1.8.0 b3 is perfect, but not frame skip 0. Mines is AMD Athlon xp 2000+ 1.67 Ghz, 512 ram

EDIT: Yesterday my chip broke so it AMD Duron(tm) 800 Mhz 512 of ram. Vba 180 is slow on gba but not gb/gbc.

revenge3
June 3rd, 2007, 11:44 AM
my pc is amd3000 1gb of ram and an invidia 512 display adapter and i have a lot of problems to wuth the v1.8 beta 3.now i play on vbalink.i'ts an amazing emulator!

Skeetendo, Inc.
June 3rd, 2007, 01:11 PM
vba 1.8.0 b3 is perfect, but not frame skip 0. Mines is AMD Athlon xp 2000+ 1.67 Ghz, 512 ram

EDIT: Yesterday my chip broke so it AMD Duron(tm) 800 Mhz 512 of ram. Vba 180 is slow on gba but not gb/gbc.

I've noticed this to, that is why its called Beta :P There is something wrong in the program, try what I recommended and download 1.7.2, that should fix the problem!

dstaley
June 4th, 2007, 04:56 PM
And if that doesn't work, I recommend getting VBALink (http://www.vbalink.info) or NO$GBA (http://nocash.emubase.de/gba.htm). Both of these emulators are much faster than the normal VisualBoyAdvance emulator.

Sadly, both of these experienced slowdowns on my computer. These slowdowns aren't permanent, and seem to be random. I've moved off from the emulator scene as I have been trying to beat the Elite Four on Pokemon Diamond >>'

jonicito
June 8th, 2007, 12:25 PM
Since my computer is slow, vba 1.7.2 has slow motion in some games. I'm getting AMD athlon 64 processor 3000+ 512 of ram and ATI card. My current video is All-in-wonder Radeon. Stephen need to get vba 180b3, he has no internet, and he's tired of slow motion, His sys is Pentium(r) 4 cpu 2.66 512 of ram, but I don't kow his video system.

SytheXP
June 20th, 2007, 07:39 PM
Personally I use normal vba but also have no$gba and vbalink but also you dont really need the sound on so turn it off it helps speed it up. Thats an option. I keep mine off and mine runs to fast.

Rumor
June 28th, 2007, 03:42 PM
I can get mine up to 600% using the space bar to speed it up.

Jirachi3
July 22nd, 2007, 07:16 PM
One thing i've noticed, is the sound. If you have sound on, it runs at an average speed, when you put it on mute it goes about 50% slower and when you turn it off, it goes about 150% faster. Maybe you should check your sound settings.

jonicito
July 24th, 2007, 04:51 AM
Now I hae amd athlon 64 3200+ 2 ghz. I have 3 vbas, I down two from vbalink. and I have vba 1.8.0b3. When you link, It slow.