< >
Hello, guest! Please log in or register.

The PokéCommunity

Go Back     The PokéCommunity Forums > Members List MrDollSteak's Profile


MrDollSteak MrDollSteak is offline

Formerly known as 11bayerf1

Visitor Messages

Showing Visitor Messages 1 to 15 of 688
  1. Sky High
    2 Days Ago 10:22 AM
    Sky High
    Yow! The Shift Gear particle from the Move Resource Thread is broken (or should I just rip it off from your rombase LOL)
  2. GOLDstandard
    3 Days Ago 9:01 PM
    You never responded to my post in the sugimori thread so I take it you dont accept my sprites?
  3. Gamer2020
    1 Week Ago 11:32 PM
    Let me know if you have any questions. The ini has been changed slightly and I haven't provided documentation.
  4. TyHawk4501
    1 Week Ago 8:26 PM
    Hey MrDollSteak! Just thought I'd check on you, so whatcha up to? Anything new?
  5. Sky High
    1 Week Ago 6:26 AM
    Sky High
    Ahh... sorry my bad. I haven't heard of the "and" ASM command before. Sorry for being dumb. XD

    I tried your latest modification of the routine right now but I still can't get these abilities (the type changes) to be working. Dunno what exactly is wrong. I just followed everything. :/

    Is "mov r0, r6" is equivalent to "add r0, r6, #0x0"? That line is only the difference from the original decompiled routine to "add r0, r6, #0x0" I've seen on VBA's disassembler. I dunno if this really causes it.
  6. Sky High
    1 Week Ago 5:22 AM
    Sky High
    You haven't changed the Return confusion and line 39. Even I've corrected it on my own, I still can't get the Normalize and the others working. Here's how I've done it (for Emerald):
    .align 2
    .global typechangeabilities

    mov r0, r6
    add r0, #0x20
    ldrb r1, [r0]
    mov r0, r10
    cmp r0, #0x0
    bne NormalizeCheck
    cmp r1, #0xAF
    bne PixilateCheck
    mov r0, #0xF
    b StoreType
    cmp r1, #0xB7
    bne AerilateCheck
    mov r0, #0x17
    b StoreType
    cmp r1, #0xB9
    bne ReturnType
    mov r0, #0x2
    mov r10, r0
    ldr r0, .ChangeTypeLoc
    ldr r1, [r0]
    add r1, #0x13
    ldrb r1, [r1]
    mov r2, #0x3F
    add r2, r1
    cmp r2, #0x0
    bne ReturnType
    mov r2, r10
    strb r2, [r1]
    mov r0, r8
    mov r1, #0xA7
    mul r0, r1
    lsr r0, #0x7
    mov r8, r0
    mul r7, r1
    lsr r7, #0x7
    b ReturnType
    cmp r1, #0x61
    bne ReturnType
    mov r0, #0x0
    mov r10, r0
    ldr r0, [sp, #0x4]
    ldrh r0, [r0, #0xA]
    str r0, [sp, #0x1C]
    ldrh r0, [r6, #0x2E]
    cmp r0, #0xAF
    bne NoEnigmaBerry
    ldr r1, .Return
    bx r1
    ldr r0, .Return2
    bx r0

    .align 2
    .ChangeTypeLoc: .word 0x0202449C
    .Return: .word 0x0806961B
    .Return2: .word 0x08069635
  7. DraconianWing
    1 Week Ago 10:53 PM
    nvm found it n_n
  8. DraconianWing
    1 Week Ago 10:39 PM
    Where is one of the pointers to the type effectiveness table located on Emerald?
  9. Gamer2020
    1 Week Ago 7:18 PM
    Hi. I figured I should let you know that Pokemon Game Editor now supports added types. Please let me know, preferably through Github, of any other incompatibilities that come up.
  10. DraconianWing
    1 Week Ago 4:12 PM
    Where do you get the Sugimori palettes themselves? I'd like to take a shot at spriting/recoloring and see what I can do; if all goes well, maybe I can even contribute to help speed up the process.
  11. DraconianWing
    2 Weeks Ago 7:07 PM
    Thanks so much for uploading an icon replacement patch! Looks amazing
  12. GOLDstandard
    2 Weeks Ago 4:09 PM
    Do you use G3T?
  13. DraconianWing
    2 Weeks Ago 12:01 PM
    Do you still have the icon sprites image for the Fairy type in your expansion tutorial for Emerald? The attachment is still broken from when the forums were breached.
  14. GOLDstandard
    2 Weeks Ago 8:34 PM
    I have the name changed from BPRE to MrDS and the ini is replaced and FFFFFE is replaced with FFFF but I still error out when I start the rom... It's quite weird
  15. GOLDstandard
    2 Weeks Ago 11:41 AM
    Hey Mr. Dollsteak,

    I am trying to start hacking on my Mac while I'm at uni, but I can't open a ROM patched with your base in Gen III suite. I managed to get it to work on my PC at home so I don't know what's happening this time. I replaced the ini with the provided one in the patch. Any help would be appreciated


Total Posts
Activity by Forum
Visitor Messages
General Information
  • Last Activity: 4 Days Ago 4:29 AM
  • Join Date: December 8th, 2008
  • Referrals: 4


Showing Friends 1 to 20 of 30


Emblem Showcase - 1 Total
Helping Hand
This member has done some kind of service to PC; Or maybe they help out other members whenever they get the chance.
Awarded: January 16th, 2015 3:05 PM

  All times are GMT -8. The time now is 9:59 AM.

Contact Us Archive Privacy Statement Terms of Service Top