The PokéCommunity Forums

The PokéCommunity Forums (
-   ROM Hacking Hub (
-   -   Get Pokemon Hacks to work in GPsp Kai! (

Mr July 15th, 2010 5:41 AM

Get Pokemon Hacks to work in GPsp Kai!
*Note that this tutorial is not for a computer emulator, it is for GPsp Kai. To fix this error for VBA, simply open the emulator and go to Options>Emulator>Save Type> Automatic & Flash 128KB*
*Links to RHEA, Rijon Adventures, and GPsp Kai are provided*

I recently tried to start playing Pokemon: Rijon Adventures ( on my PSP to find that it wouldn't work. After a quick Google search I found a thread here at PokeCommunity where someone was having a similar problem. This tutorial will show you how to correct the 1M sub-circuit board not detected error on Hacks played on GPsp Kai 3.4 test 1 Build 2.

Step 1) Verify that hacked roms are the problem and not something else.
With this specific issue, it is possible to play an unhacked pokemon rom, but some patched hacks do not work.

Step 2) Check your patched rom with Hackmew's ROM Header Editor Advance (
With the program open, simply click File>Browse ROM Folder. Locate the folder in which your ROM is stored and it will appear in the list to the right. Any other roms that are also in that folder will show up here as well. DO NOT EDIT ANYTHING! We only want to get the official name of the rom; editing data could ruin the rom. (I learned that the hard way).
As you can see below, an un-modified Fire Red rom has the name of "POKEMON FIRE" however, some Hackers like to change the name of the ROM. Now, look at the hacked ROM. It should have a name other than that of the original ROM from which it was made. I'm fixing Pokemon Rijon Adventures and its name is "RIJON ADVENT". Copy this name into a notepad or something, you'll need it later. If your rom has any name other than the original then proceed to step 3, if it does not then I'm afraid that this tutorial is of no help to you. You could always try anyway, though.

Step 3) Add the hacked rom to GPsp Kai's configuration list. (Don't worry, it's simple)
I can't verify which versions of GPsp kai use the same system as the version I have, so I'll provide a link to the exact version I'm using.
If that link is broken, then check the version information in the screenshot above and search for a download on Google. You should be able to find another download. If not, PM me.
I will assume that you know how to install the emulator on your PSP. After all, you're just replacing the version you already have, unless you don't need to update it. If you do need help on this subject, look on YouTube.
Now that you have everything, find and open the config file. (See image below)
open it in notepad, wordpad, or whatever program you like, but you'll want a search function. Most programs do. Search for the name of the ROM you used to patch the Hack on to. Mine is Fire Red. You will see somehing like this:
This is where the game name comes in! An un-modded Fire Red rom (amongs all of the others) works because its save type is in the configuration. A hack with a special Name is not configured. So here is how you add it.
You want to copy all of the original ROM's info, but replace the game_name with that of the hack. Mine would look like this:

# Pokemon: Rijon Adventures
game_name = RIJON ADVENT
game_code = BPRE
vender_code = 01
idle_loop_eliminate_target = 080008c6
flash_rom_type = 128KB

The 1st line has a # at the front. When you put a # that line is for out human eyes only. The emulator ignores it. This is how you add notes and stuff. You'll noteice that every ROM has it's name after one so it can be found by us easily. :)

The second line is where you would place the name you copied down earlier.

I don't know the relevance of the 3rd, 4th, and 5th lines, but they must be there. Just copy them. They will be the same as the base ROM.

The 6th line is the save type. This is what causes the error. Now that we have set it to 128KB in the config file, everything should work! Don't forget to save the file! :)

Step 4) Cleanup to reset
If you opened the ROM in your emulator and got the error, a save and config file would have been created for it upon closing. We don't want the changes we have just made to be overlooked, so delete any .cfg files that were associated with that specific ROM. In my case it would be Pokemon Rejion Adventures.cfg

Now load the game again and there will be no error! You can save the game through the save option in the Pokemon menu and that will create a .sav file. This type of save can be transfered from PC to PSP and back, the quick save states can't do this. VBA uses .sgm quickies and GPsp uses something like .sg1s.

I hope you have found this tutorial helpful! If you need anything else, just PM me! :D

Mr January 6th, 2012 11:57 PM

This method may work for various versions of GBA emulators on the PSP. I'm thinking of uploading a .cfg file that supports loads of Pokemon hacks. I would assume that most of them will work by default anyway. The only ones that suffer are the ones where they actually changed the ROM's official Header name.

~I've gotten a few people that were asking for help. Maybe sometime soon I'll just update all of this and provide a .cfg file.

jkyriac March 4th, 2013 10:29 AM

Hey dude, let me just say i found your tutorial to be plain awesome. Still, it didn't fix my problem, can you help me out?
I want to play pokemon pinball sapphire and ruby, i can play other games and followed all your steps, but i'm still getting a white screen. Any ideas?

Thanks in advance:)

Mr March 7th, 2013 5:26 PM


Originally Posted by jkyriac (Post 7564592)
Hey dude, let me just say i found your tutorial to be plain awesome. Still, it didn't fix my problem, can you help me out?
I want to play pokemon pinball sapphire and ruby, i can play other games and followed all your steps, but i'm still getting a white screen. Any ideas?

Thanks in advance:)

This tutorial is only meant to get the emulator to recognize games with a custom header.
You're talking about a regular GBA game.

After a quick Google search, I believe it is the emulator itself that is the problem. Try an official release of that emulator. kai was a copy and the original dev didn't approve of it's creation. I know newer versions of GBA emulators were released, so that being said. Start there.

I haven't had a working PSP in years, so I can only help you by what I can remember and search for.
As we say in the IT field, Google is your friend!
(Albeit, sometimes you have to know what exactly to search for.)

jkyriac March 7th, 2013 11:39 PM

Thanks for replying. I do believe you may have solved my problem, i'll post again should anything new pop up. I'll look into new emulators like you said.

Thanks again for trying to help out, appreciate it :)

All times are UTC -8. The time now is 12:53 PM.

Like our Facebook Page Follow us on Twitter © 2002 - 2015 The PokéCommunity™,
Pokémon characters and images belong to The Pokémon Company International and Nintendo. This website is in no way affiliated with or endorsed by Nintendo, Creatures, GAMEFREAK, The Pokémon Company or The Pokémon Company International. We just love Pokémon.
All forum styles, their images (unless noted otherwise) and site designs are © 2002 - 2014 The PokéCommunity / Poké
PokéCommunity™ is a trademark of The PokéCommunity. All rights reserved. Sponsor advertisements do not imply our endorsement of that product or service. User generated content remains the property of its creator.

Use of PokéCommunity Assets