View Single Post
  #59    
Old July 26th, 2008, 03:24 PM
score_under's Avatar
score_under
I program the *other* ASM.
 
Join Date: Aug 2005
Location: Hertfordshire, England
Age: 21
Nature: Rash
This post applies to an OLD version of the program only, If you're wondering why I'm writing this little header message, it's because I called the updates "new" when they're rather old now.
Quote:
Its a looks a great program but doesn't work on the shell.bat thing it just say access denied and I can't use some programs and more with the alzip and one of the programs is advance map.so can you plz plz plz help???
The associateshell.bat needs to be run as administrator to associate it system-wide.
I don't understand the second part of the sentence, that you "can't use some programs and more with the alzip and one of the programs is advance map".

Quote:
You're not going to tell people about the update with the toolbar? I guess its pretty minor.

Do you think you could make something that would make deleting scripts already in the game easy? I just need it for my emerald hack as I am running out of space fast. Maybe even just something that gives the offset of the end of the script (so I don't have to look for that 02 manually).
I was guessing that people would notice the toolbar for themselves :p It's taking up a whole... about 26 pixels height? Something like that. Could have been 22. Not 24 though.
About the script eraser, I may try after I go to sleep (it's rather late) but wouldn't it be more efficient to erase old maps, as they love to take up space?

Quote:
Hey this is a really cool script, I just started using it yesterday and I love it.

I just have one problem.

I made a script for a character and it worked perfectly. Then I tried making another script for a different character, and that worked too. But when I went to talk to the first character it said the same thing as the second character.

Help, please?
You either used the same "#org" offset for both your scripts' text blocks, or you mispointed a msgbox command.

By the way, this seems to be the ONLY script editor which correctly decompiles "jump" (i.e. ends decompilation at that point, as if it were return or end) and the ONLY one which de/recompiles movement data! *at time of writing

With regards, again, to dshayabusa...
It now has a toolbar! Go wild!

EDIT:
Spoiler:

This is what XSE (incorrectly) does at this offset:
0001
0002
0003
0004
0005
#org 0x16A689
msgbox 0x819133C '"All right!\nLet's get happening!"
callstd 0x4
goto 0x816A6A5
end

This is what PKSV (correctly) does at this offset:
1 -
2 |
3 |
4 |
5 \
#org 0x816A689
'-----------------------------------
msgbox 0x819133C ' All right!\nLet's get happening!
callstd MSG_NOCLOSE ' Non-closing msg
jump 0x816A6A5

If you are going somewhere else, it WON'T still execute the script, so DON'T decompile it. There's not meant to be an "end" statement on that script fragment!
__________________
Plz not to PM me, I don't come here often enough. Email if you need me

Last edited by score_under; August 23rd, 2008 at 04:52 AM.