Thread: [Tutorial] HackMew's Knowledge
View Single Post
Old July 8th, 2009 (8:40 AM).
HackMew's Avatar
HackMew HackMew is offline
Mewtwo Strikes Back
Crystal Tier
Join Date: Jun 2006
Posts: 1,314
Quote originally posted by -DarK-:
Ah thank you, it worked. I thought bytes were overwrited already when you just pasted it.

EDIT: Ok, I tried something out, but it didn't work:

.align 2
.global test1

push {r0-r1, lr}
ldr r0, .WILD_NEW
ldr r0, [r0]
ldr r1, .WILD_DATA
ldrh r0, [r0, #0x8]
strh r0, [r1]
pop {r0-r1, pc}

.align 2
.word 0x00810000
.word 0x003C8F00

I tried using this to change wild data for Route 1. The first rattata in the list was supposed to be changed to an arbok, but it didn't work, so it seems. I kept encountering the usual pidgey's and rattata's (tried around 20 - 30 encouters, didn't find it).

Here's my script (a simple lvl script):

#dynamic 0x800000

#org @start
checkflag 0x201
if b_true goto @stop
callasm 0x810009
setflag 0x201

#org @stop
I'm new to ASM, and I'm not sure what I missed out, so can someone help?
Like I told you already, you can't edit the ROM as it's Read-Only Memory. Even if the ASM routine was correct, it would never work.

Quote originally posted by JohnPaulJones:
Hackmew, I have a problem.
I extraced the .asm rountines into a folder named "thumb" on my desktop, which contains the assembler. The first time I tried to assemble, the routine opened in Visual C++ I have installed on my computer. But, whenever I try and run the command prompt as
C:\Documents and Settings\Name\Desktop>thumb lesson1.asm lesson1.bin
I get the message
'thumb' is not recognized as an internal or external command, operable 
program or batch file.
I have little experience with command prompts, so did I mis-type something? Or is it another problem I am having?
Well... The problem is your using the wrong folder. Type "cd thumb" without quotes and try again. If you extracted everything from the zipped archive into your thumb folder, it will work.
Reply With Quote