View Single Post
  #28    
Old March 5th, 2010, 06:29 PM
BlitŻ's Avatar
BlitŻ
guahh my dog is so cute
 
Join Date: Feb 2009
Location: Bay Area, Califronia.
Age: 19
Gender: Male
Nature: Jolly
Tournaments Joined: 0
Tournaments Won: 0
Quote:
Originally Posted by PeregrineFig View Post
I'm having an annoying issue with hex editing anything. I attempted to edit the intro of FireRed using the original method in the first post. I found the old text, highlighted it all and deleted it, then translated my new text into the hex code on notepad, copied it, and used Paste special, picked CF_TEXT, and checked interpret as hexadecimal string. Everything looked right, so I saved and opened my ROM. I got nothing but a white screen, nothing would load. I backed up my ROM and tried again, same result. Eventually that hack got scrapped because I made a blunder and broke some important stuff, but anyway, I tried editing Birch's intro in Emerald for a new hack. I only changed 2 words, but I used the same method of deleting and pasting. Again, blank white screen. This is incredibly frustrating, am I doing something wrong with my method of hex insertion? I'd really like to know how to fix this. If anyone will help me out here, then thank you.

Edit: After experimentation I'm convinced I'm just doing something wrong here. I tested this again and just replaced a single character, and instead of deleting/pasting, I typed the new hex value over the old one, and everything worked fine. My new issue is, how can I add a character? If the new hex I enter in has the same amount of characters as the old, it runs properly. But if it has more or less, it just breaks my ROM.
Your new text has too acommodate to the number of bytes that it allows. Let's say one page let's you use ten bytes, using the table file, you can have 10 of any character of command (\n,\l,\p). Your pasting/deleting method destroys your rom . You basically write over the previous bytes.

Quote:
Originally Posted by Tomato Cat View Post
If anyone could help me: I'm having trouble editing my third page. Instead of showing the text I input in hex, it shows the last word of the second to last line and the full last line of the second page.

Does anyone know what's causing this problem?
I'm confused by your description of error, please provide screeny's xD

Last edited by BlitŻ; March 5th, 2010 at 06:31 PM. Reason: Your double post has been automatically merged.