View Single Post
  #4901    
Old November 10th, 2010 (06:33 AM).
Jm20's Avatar
Jm20 Jm20 is offline
A.k.a. Zig :-)
 
Join Date: Sep 2009
Location: The Netherlands
Age: 22
Gender: Male
Posts: 88
Okay, some of my script-tiles aren't working properly. I inserted a variable/flag value in the "Script Value" box, namely 1011. I gave two Overworld a PersonID of that value too, since the OW's and the script have to appear at the same time. Settings of the scripttile event:

That flag was set in the levelscript of the first map. It was unset in the following script:
Code:
'---------------
#org 0x72001C
setvar 0x7005 0x1
lock
faceplayer
applymovement 0x1 0x816BA66
waitmovement 0x0
msgbox 0x816B893 0x6 '"[blue_fr]blah1"
applymovement 0x1 0x816BA69
waitmovement 0x0
msgbox 0x816B95C 0x6 '"[black_fr]blah2"
applymovement 0xFF 0x816BA6E
waitmovement 0x0
applymovement 0x1 0x816BA72
waitmovement 0x0
applymovement 0xFF 0x816BA75
applymovement 0x1 0x816BA78
waitmovement 0x0
setvar 0x1016 0x1
hidesprite 0x1
clearflag 0x1011
release
end


'---------
' Strings
'---------
#org 0x16B893
= [blue_fr]blah1

#org 0x16B95C
= [black_fr]blah2


'-----------
' Movements
'-----------
#org 0x16BA66
#raw 0x62 'Exclamation Mark (!)
#raw 0xFE 'End of Movements

#org 0x16BA69
#raw 0x1 'Face Up
#raw 0x1C 'Delay5
#raw 0x4A 'Face Player
#raw 0xFE 'End of Movements

#org 0x16BA6E
#raw 0x20 'Step Right (Fast)
#raw 0x2 'Face Left
#raw 0xFE 'End of Movements

#org 0x16BA72
#raw 0x10 'Step Down (Normal)
#raw 0xFE 'End of Movements

#org 0x16BA75
#raw 0x0 'Face Down
#raw 0xFE 'End of Movements

#org 0x16BA78
#raw 0x10 'Step Down (Normal)
#raw 0x10 'Step Down (Normal)
#raw 0x10 'Step Down (Normal)
#raw 0xFE 'End of Movements
After this you walk through a warp and you come in the map where the script tiles and OW's are. Now... The OW's do appear, but the scripttiles don't. That's strange, isn't it? I'm using Fire Red JPANs Hacked Engine etc... But why aren't the script tiles appearing? I personally think it is something with messing up flag and variables and that I shouldn't use some "numbers" as a variable, only as flag, or something similar... But I'm confused right now...