View Single Post
  #7413    
Old November 6th, 2012 (07:17 PM). Edited November 6th, 2012 by Renegade.
Renegade's Avatar
Renegade Renegade is offline
Time for real life...
 
Join Date: Nov 2011
Location: United States
Gender: Male
Nature: Careful
Posts: 998
Quote originally posted by SK3:
Spoiler:
#dynamic 0x2A3900
#org @start
msgbox @talk1 0x6
playsong 0x013B 0x0
applymovement 0x04 @walk1
waitmovement 0x0
applymovement 0xFF @walk2
waitmovement 0x0
msgbox @talk2 0x6
applymovement 0x04 @walk3
waitmovement 0x0
hidesprite 0x04
fadesong 0x0151
setvar 0x6002 0x1
setflag 0x1207
release
end

#org @walk1
#raw 0x12
#raw 0x12
#raw 0x12
#raw 0x12
#raw 0x12
#raw 0x12
#raw 0x12


#org @walk2
#raw 0x62
#raw 0x3

#org @walk3
#raw 0x13
#raw 0x13
#raw 0x13
#raw 0x13
#raw 0x13
#raw 0x13
#raw 0x13


#org @talk1
= Hey! [player]! Wait!

#org @talk2
= Finally woke up huh?\pDo you not realize what day\nit is?\pWell at least you are up now,\nwe've got to get down to the lab!\pI'll see you there.


This script always stops after the first applymovement....what's wrong?
After all of your movement strings, you need a #raw 0xFE.
So after every one of your @walk #raw commands, you need #raw 0xFE.
That tells the game that the movement is over.

Quote originally posted by Naruto200:
I'm no expert but try putting the playsong before the textbox command. Also fadedefault unless you're trying to make it fade to a different song than the original.

Also make the text #org's before the movement #orgs.

That might help.
(Sorry I can't help more, but I'm just getting into this and making my creepypasta)
Please try not to post solutions if you don't think they are valid... It's kinda annoying.