View Single Post
  #23668    
Old February 1st, 2013 (01:03 PM). Edited February 1st, 2013 by karatekid552.
karatekid552's Avatar
karatekid552
What happens if I push it?....
 
Join Date: Nov 2012
Location: Do you really want to know? Really?
Gender: Male
Nature: Bold
Send a message via AIM to karatekid552 Send a message via Windows Live Messenger to karatekid552 Send a message via Skype™ to karatekid552
Quote originally posted by Noossab Blue:
Is there a way to define a trainer's pokemon by a variable? For example, telling it to use the value stored in var 0x5000 as the species of pokemon?
See my response to you in the script help thread.

Quote originally posted by Flame999:
one question how would i go about getting a pokemon roaming in fire red if there's a thread the put a link to it I'm just wondering as r/s/e has lati twins and Fire red has Legendary dog based on your starter but is it possible to add one or two?
I'm pretty sure JPAN included this in his hacked engine. See the documentation for it.

Quote originally posted by BullZai:
I have this question, and I'm sure it has been asked a hunderd times, but with the mighty power of google and the forums search engine I been unable to find a solution. Although I found one person with the same question, the answer was simply "There shouldn't be a problem."

(This whole problem concerns XSE and Advance Map)

The problem is that I've made this quite big script consisting of 250 lines, which i'm not sure is completely working, and I'm trying to compile it in my ROM. I've tried the most used ways of compiling that worked for me when I had to use it for message scripts, but the ways I tried it is by clicking the gears, and the batch compile tool. I already loaded the rom in XSE.
I also tried to put both the offset i used after #dynamic and the offset the compile-menu gave me with the @start.

When I insert the script offset, and I open it, the script consist of an line, followed by #org 0xOFFSET.

Sorry for asking the question that is asked a million times, but search engines don't give me a valid answer. If I need to be any clearer, just ask me, and I'll just clarify it.
Make sure you are running XSE 1.1.1. I have had some problems with the old one not branching out and finding the other half of long scripts I have written.

Now, the @start offset must be the very first dynamic offset in your script (which I am sure you know). Take the offset given to you by XSE and put it in A-map. Verify that it is the exact same number, just preceded by a '$'.

If just checking for mistakes doesn't work, please post the script for us to look at. (Please use [spoiler] or [code] tags)
__________________

Paired with Simba