View Single Post
  #23897    
Old February 18th, 2013 (01:20 AM).
DrFuji's Avatar
DrFuji DrFuji is offline
Helfen, Wehren, Heilen
Crystal Tier
 
Join Date: Sep 2009
Location: Downia-upside
Age: 22
Gender: Male
Nature: Jolly
Posts: 1,322
Quote originally posted by The Legacy of The Legends Creator :D:
what is the message script command i put
"msgbox @sign 0x3"

and a pop up comes up when i hit compile that prevents me to progress stating

Error 13 'Type mismatch' on line 4
Missing #define or parameter

Line:msgbox @sign 0x3

I am also having trobble with this one
I have been using Advance series for sprites and i get this


How do you do it with GIMP, if its easier or not lol idc as long as ill get better results XD <3
The regular and shiny versions of Pokemon can't have different sprites attached to them as that just leads to the problems you're seeing in the editor. The ROM cuts a few corners when it comes to shinies so unless you manage to change the way the game loads and stores the sprites through some unknown ASM or HEX editing then you're you're restricted to using the same sprites.

Essentially the ROM has one set of sprites for each Pokemon (a frontsprite and a backsprite obviously) but the backsprite contains the shiny palette. This palette overwrites the regular coloured palette when a shiny is activated but since it is just overwriting the palette rather than changing the active sprite you don't have any opportunity to change what it looks like. Game Freak managed to save space on the ROM by doing this, as that meant they only had to insert two sprites rather than four in the event of shinies, relying on the palette swap to do the rest for them.

Long story short, you have uploaded different front/ back sprites with your shiny variations and tried to sync palettes. But since the Advanced Pokemon Sprite Editor knows the ROM's limitations it has tried to merge the shiny and regular sprites together, leading to look glitched and weirdly coloured in some areas. Just keep the sprites the same but alter the palette when it comes to shiny versions.

Ugh, sorry I feel like I'm rambling and not adding anything :P

Quote originally posted by The Legacy of The Legends Creator :D:
i have "v1.0.0"
XSE 1.0.0 is very glitchy and shouldn't be used at all. Here's a link to v1.1.1 which should be able to insert your earlier script perfectly.
__________________