I don't see why you couldn't rename those "something"s into more meaningful names. Right now those might as well be hex offsets, since they give about the same information as "something".
The point is that if you are asking people for suggestions to optimize your code, you should not make them have to re-research everything themselves.
At the very least you could comment what you're trying to do. If you just changed some pointers at the end and don't really know whats going on, that's a different story.