View Single Post
  #8077    
Old March 26th, 2013, 05:32 PM
karatekid552's Avatar
karatekid552
What happens if I push it?....
 
Join Date: Nov 2012
Location: Do you really want to know? Really?
Gender: Male
Nature: Bold
Send a message via AIM to karatekid552 Send a message via Windows Live Messenger to karatekid552 Send a message via Skype™ to karatekid552
Quote:
Originally Posted by Bolens View Post
Game: Firered Type: Level Script Editor: XSE Script:
Spoiler:
#dynamic 0x745800

#org @start
lockall
applymovement 0xFF @4
waitmovement 0x0
applymovement 0x9 @1
applymovement 0xA @2
waitmovement 0x0
msgbox @3 0x6
msgbox @string1 0x6
applymovement 0x9 @5
waitmovement 0x0
trainerbattle 0x0 0x5C 0x0 @6 @7
applymovement 0xA @8
waitmovement 0x0
trainerbattle 0x0 0x5D 0x0 @9 @10
msgbox @string2 0x6
giveitem 0x44 0x2 MSG_OBTAIN
msgbox @12 0x6
applymovement 0x9 @13
waitmovement 0x0
applymovement 0xA @14
waitmovement 0x0
hidesprite 0x9
hidesprite 0xA
setflag 0x1006
setvar 0x7003 0x1
releaseall
end

#org @1
#raw 0x62
#raw 0x3
#raw 0xFE

#org @2
#raw 0x62
#raw 0x3
#raw 0xFE

#org @3
= Grunt 1: Well look what we have\nhere, a nosy boy in our affairs.

#org @string1
= Grunt 2: Let’s teach him a\nlesson.

#org @4
#raw 0x11
#raw 0x11
#raw 0x2
#raw 0xFE

#org @5
#raw 0x10
#raw 0x13
#raw 0x13
#raw 0x11
#raw 0x3
#raw 0xFE

#org @6
= Prepare to lose!

#org @7
= How could you possibly defeat\nme!!!!

#org @8
#raw 0x11
#raw 0x13
#raw 0x13
#raw 0x0
#raw 0xFE

#org @9
= I won't be easily beaten unlike\nmy team mate!

#org @10
= Me too!! ugh!!

#org @string2
= Grunt 1: You beat us fair and\nsquare. Take these Rare Candies\lthey’ll help your Pokemon get\lstronger.

#org @12
= Grunt 2: Alright, we’ll be on\nour way, let’s go.

#org @13
#raw 0x10
#raw 0x13
#raw 0x10
#raw 0xFE

#org @14
#raw 0x12
#raw 0x10
#raw 0x10
#raw 0x10
#raw 0x13
#raw 0x0
#raw 0xFE

Problem: XSE crashes whenever I try to compile this into my ROM. This keeps happening, IDK why. Hopefully someone can help, thanks guys.

~Bolens
I see no reason why XSE should be crashing. Are you using v1.1.1? Also, I see that you are using flags over 0x900. You do know the potential consequences if you aren't careful, right? (I am assuming you have been around a while:p)

The only possibilies are you have a faulty copy of XSE, or it doesn't like your @# labels. Try using words; it may work. I have written scripts ten times longer than this with no problems, so it shouldn't be the volume of your script which is causeing it.
__________________

Paired with Simba
Reply With Quote