View Single Post
  #8122    
Old April 18th, 2013 (02:30 AM).
karatekid552's Avatar
karatekid552 karatekid552 is offline
What happens if I push it?....
Team Johto
 
Join Date: Nov 2012
Location: Do you really want to know? Really?
Gender: Male
Nature: Bold
Posts: 1,767
Send a message via AIM to karatekid552 Send a message via Windows Live Messenger to karatekid552 Send a message via Skype™ to karatekid552
Quote originally posted by lemonzap:
I moved the people who were being told to move closer and now that works but still no messages show up. I changed the message types to 0x6 and added a setvar but it didnt change anything. I've read through that tutorial before but have not been able to find any information on the s-tiles in there so I've just been trying things out. Also I don't know if this could be related but when I try to make a level script that displays a message it just displays

This is a test message
this is a signpost

over and over again. Everything else in the level script works fine, just not messages. just like my s-tile script.

Thanks for the help. I really appreciate the speedy reply.

I've been trying to make more scripts and I have not been able to make a message display yet. I have even tried copying example scripts directly from tajaros' tutorial and using them in both emerald and fire red. I cant figure out what I'm doing wrong.

I finally fixed my problem. I had to add

boxset <message type no.>

after each message. for instance this would not work

lock
msgbox @wait 0x6
release

but this does work

lock
msgbox @wait 0x6
boxset 6
release
By this description, you are using an old version of XSE. V1.0.0 most likely. Go to Gamer2020's toolbox. There you will find his most recent version (just a couple of weeks ago, if that) which has had several bugs fixed.
__________________

Paired with Simba