View Single Post
Old May 28th, 2013 (2:48 AM).
BlackWhiteRobin's Avatar
BlackWhiteRobin BlackWhiteRobin is offline
Join Date: Sep 2012
Location: Want to know? VM me.
Age: 17
Gender: Male
Nature: Quirky
Posts: 431
Send a message via Windows Live Messenger to BlackWhiteRobin
Quote originally posted by karatekid552:
Well, you simply eliminate the checks for shiny pokemon. In my research, I came across the palette loader for shinies. After some crazy calculations on the PID:p, it simply compares the output to 7. If less than, it loads the shiny palettet, if not, it loads the regular palette. I'm sure similar routines are used to load the stars and such. If you change those checks to "nop", then it should never use them and no shiny should ever appear.
Oh hey it's karatekid552! About that, where could those checks be?

And about this:
Quote originally posted by robin22gongon:
2) I'm trying to compile this script:
#dynamic 0x750000

#org @start
checkflag 0x1
if 0x1 goto @ka
checkflag 0x2
if 0x1 goto @fuu
checkflag 0x3
if 0x1 goto @rai
checkflag 0x4
if 0x1 goto @do
checkflag 0x5
if 0x1 goto @sui

#org @ka
warp 0x3 0x1 0x1 0xC 0xC

#org @fuu
warp 0x3 0x2 0x1 0xC 0xC

#org @rai
warp 0x3 0x3 0x1 0xC 0xC

#org @do
warp 0x3 0x4 0x1 0xC 0xC

#org @sui
warp 0x3 0x5 0x1 0xC 0xC
It should warp to a map according to the flag set but it doesn't work. That is originally made for a Signpost event but it didn't work. I tried setting it on a Script Event, didn't work, again. (Note: Of course I set the Var Thingies on the Script Event!) And I tried it on a Person Event but it didn't work either. What's wrong?
Is what destinedjagold said right, which is "2. Try changing the flags that you are checking. I believe those flags you are using are automatically being restarted by the ROM."?

And I'm using JAPN's FR Engine.