View Single Post
  #47    
Old July 24th, 2013 (01:05 AM). Edited July 26th, 2013 by MrDollSteak.
MrDollSteak's Avatar
MrDollSteak MrDollSteak is online now
Formerly known as 11bayerf1
 
Join Date: Dec 2008
Location: Hong Kong
Age: 20
Gender: Male
Posts: 566
Quote originally posted by Jambo51:
True, but when it works for myself, Linkandzelda and him/her, it does imply that the code is sound, and you are simply messing something up. That said, I have no idea how you could mess it up, especially given that you posted precisely HOW to actually insert the ASM.

Are you sure you're using BPRE 1.0? That's the only thing I can think of which could cause the errors you're getting.
Count me in aswell. I initially had problems with the very original Var hack, but the most recent one works 100%. I added it to both a blank rom first, and then my actual hack, which has quite a few routines and things in and it still worked fine.

That being said I haven't tried setting any of the vars yet. But the game runs and I can move fine. I'll update this message once I start setting the vars.

EDIT: I've used vars 5000, 5001 and 5002 setting them to different values up to 0x8 and have experienced NO problems.

EDIT2: One thing I have noticed though. Is that with the Flag Hack, a few of the flags aren't working. In the sense that I give them to NPCs, and after the flags are set the NPCs are still visible. So far I've been using flags from 900-915 and the flags that don't correctly turn off NPCs are
901, 903, 904, 906, 907, 90F, 910. These are the ones I know of. Has anyone else been experiencing problems with setting these newer flags?

EDIT3: With further inspection it seems that the range actually seems to be 900-907
__________________
Reply With Quote