Go Back   The PokéCommunity Forums > Creative Discussions > Game Development > Pokémon Essentials
Reload this Page [Question] BGM won't play.

Notices
For all updates, view the main page.

Pokémon Essentials All questions and discussion about Pokémon Essentials, the Pokémon game kit for RPG Maker XP, go in here. Also contains links to the latest downloads and the Essentials Wiki.



Reply
 
Thread Tools
  #1    
Old November 5th, 2012 (11:11 PM). Edited November 7th, 2012 by ambalance.
ambalance's Avatar
ambalance ambalance is offline
Vorpal_Rabbit
 
Join Date: Apr 2008
Location: N/a
Gender:
Nature: Jolly
Posts: 9
Hey guys.

I'm working on a massive project, fakemon and all, and I have hit a little bump in development.
Up until recently, my BGM has been playing 100% fine. But two days ago while debugging for the
first demo, my BGM files wiped themselves (having 0 bytes as their apparent size.) I reimported all
the music into the game again, but since then I have been having issues when putting it into the game.

My first issue is that when you battle a trainer, no BGM plays. I have set up the global metadata so that "trainer battle BGM.mp3" is the default setting. But music doesn't play. one attempt to solve this, was to edit the metadata for each individual map, and set the map's unique trainer BGM as "trainer battle BGM.mp3". Still no dice.
For my second attempt to fix the issue, I edited the PBS trainertypes.txt and trainernames.txt so that "trainer battle BGM.mp3" is the 'unique' BGM to be played for each different trainer type (except for Leaders, Elite Four, Champion, Rocketesque enemy faction members and the Rival.) But still, nothing plays.

NOTE: the only exception is that BGM plays perfectly fine for the BUG CATCHER trainer type, regardless of where I define the trainer battle BGM. Odd hey? :/

My second issue is that for a two of the main towns (being Gym 1 & Gym 4), the unique BGM I want to play when visiting each town doesn't work. Instead, either the BGM from the previous Route continues playing, or the town is just dead silent. I tried to create a Parallel Process event to play BGM in the town, but it somehow managed to overlap the Route's BGM and play the Town's there instead. I know I can fix the issue if I separate the connections, (i.e put a gatehouse between the routes, but I don't really want to. I feel it will ruin the aesthetic of the mapping.

Any suggestions on how I can fix either/both of these? I'm confused, and I've urn out of options.

Thanks.
EDIT: I've re imported all BGM files again, including alternative battle themes. Still no change. PLEASE HELP!?
__________________
Signature:
Writer/Mapper/Eventing/Scripter/Spriter.

Also, writer.
Reply With Quote
Reply
Quick Reply

Sponsored Links
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are UTC -8. The time now is 12:23 PM.