The PokéCommunity Forums  

Go Back   The PokéCommunity Forums > Creative Discussions > Game Development > Pokémon Essentials
Sign Up Rules/FAQ Live Battle Blogs Mark Forums Read

Notices

Pokémon Essentials All questions and discussion about Pokémon Essentials, the Pokémon game kit for RPG Maker XP, go in here. Also contains links to the latest downloads and the Essentials Wiki.


Advertise here

Reply
 
Thread Tools
  #1    
Old November 9th, 2012, 10:15 AM
~JV~'s Avatar
~JV~
Dev of Pokémon Uranium
 
Join Date: Aug 2007
Location: Rio de Janeiro
Age: 20
Nature: Relaxed
Send a message via Skype™ to ~JV~

Advertise here
Hey guys, this issue happened on the last few weeks and it's one of the first times I have NO IDEA on what's going on and how to fix. As the title says, trainer BGM isn't working nad I've already narrowed down the problem, but still can't find a solution. Here is what I know:

-It has nothing to do with scripts, I tried using the default Essentials script files and it still doesn't work (I never made changes to any audio related script...).

-It has nothing to do with the mp3 file.

-When I do a DEBUG trainer battle THE BGM PLAYS.

-In Gym/Rival battles IT WORKS (can this be related to pbtrainerend or pbnoticeplayer etc??).

-Wild battles are fine.

-Cries, menu sounds... everything else plays just fine, it's just the bgm that has problems.


Don't come suggesting workaround please, I need solutions =/. BTW, I get no error windows...
__________________
Sig in maintenance!

Last edited by ~JV~; November 9th, 2012 at 10:29 AM.
Reply With Quote
  #2    
Old November 9th, 2012, 12:50 PM
Luka S.J.'s Avatar
Luka S.J.
S.J.Ware HD
 
Join Date: Dec 2008
Age: 21
Gender: Male
Nature: Adamant
Check the bit-rate of the mp3 file. If it is something like 320 kbps it won't work. I had the same problems. I found that 128 kbps works the best with RMXP, but if you want higher quality, 220 kbps worked for me as well. I haven't tested out too many mp3 files, but higher than that, never worked for me.

If the problem is what I suggested, Audacity can easily export your mp3 files in 128 kbps bit-rate.
__________________
[STOPPED][DEMO] Pokemon Blue Chrome
[DEVELOPING] S.J.Ware
[DEVELOPING] Tykanite
Reply With Quote
  #3    
Old November 9th, 2012, 01:08 PM
~JV~'s Avatar
~JV~
Dev of Pokémon Uranium
 
Join Date: Aug 2007
Location: Rio de Janeiro
Age: 20
Nature: Relaxed
Send a message via Skype™ to ~JV~
Quote:
Originally Posted by Luka S.J. View Post
Check the bit-rate of the mp3 file. If it is something like 320 kbps it won't work. I had the same problems. I found that 128 kbps works the best with RMXP, but if you want higher quality, 220 kbps worked for me as well. I haven't tested out too many mp3 files, but higher than that, never worked for me.

If the problem is what I suggested, Audacity can easily export your mp3 files in 128 kbps bit-rate.
I've tried that... I've tried using midis, using .ogg... nothing works. It isn't script, it isn't pbs, it isn't the audio file. No matter what I do, regular trainer bgm won't play. I have no idea if a file could have gotten corrupted or something. This is the weirdest bug I faced since 2008. =/
__________________
Sig in maintenance!
Reply With Quote
  #4    
Old November 9th, 2012, 01:11 PM
Luka S.J.'s Avatar
Luka S.J.
S.J.Ware HD
 
Join Date: Dec 2008
Age: 21
Gender: Male
Nature: Adamant
Try replacing or removing the Audio dll. I don't know what else to say, at first it sounded just like simple RMXP incompatibility. Is it like that for all Trainer Battle BGMs or just one?
__________________
[STOPPED][DEMO] Pokemon Blue Chrome
[DEVELOPING] S.J.Ware
[DEVELOPING] Tykanite
Reply With Quote
  #5    
Old November 9th, 2012, 02:17 PM
~JV~'s Avatar
~JV~
Dev of Pokémon Uranium
 
Join Date: Aug 2007
Location: Rio de Janeiro
Age: 20
Nature: Relaxed
Send a message via Skype™ to ~JV~
Audio.dll isn't part of Essentials anymore. I noticed the game hangs for a couple of seconds the first time I get noticed by a trainer. This probably has to do with it since it didn't use to happen.
__________________
Sig in maintenance!
Reply With Quote
  #6    
Old November 9th, 2012, 07:09 PM
ambalance's Avatar
ambalance
Vorpal_Rabbit
 
Join Date: Apr 2008
Location: N/a
Gender:
Nature: Jolly
I've recently encountered the same issue. As in, the exact same. My trainer battle BGM doesn't work for any trainers, save for a BUG CATCHER. I attempted reimporting the music files, testing to see if other extensions would work, changing the unique BGM for each trainer, each map and even trying to play a BGM with a script. Nothing worked.
I even copied my entire game's data to the updated version of Essentials, but I am having the same issue. Can anyone help us?

I'm pretty sure it isn't down to the bitrate of the BGM files, seeing as my desired BGM works in a battle with a bug catcher, but not for a youngster, firebreather, cooltrainer, etc.
__________________
Signature:
Writer/Mapper/Eventing/Scripter/Spriter.

Also, writer.
Reply With Quote
  #7    
Old November 10th, 2012, 05:14 AM
~JV~'s Avatar
~JV~
Dev of Pokémon Uranium
 
Join Date: Aug 2007
Location: Rio de Janeiro
Age: 20
Nature: Relaxed
Send a message via Skype™ to ~JV~
Quote:
Originally Posted by ambalance View Post
I've recently encountered the same issue. As in, the exact same. My trainer battle BGM doesn't work for any trainers, save for a BUG CATCHER. I attempted reimporting the music files, testing to see if other extensions would work, changing the unique BGM for each trainer, each map and even trying to play a BGM with a script. Nothing worked.
I even copied my entire game's data to the updated version of Essentials, but I am having the same issue. Can anyone help us?

I'm pretty sure it isn't down to the bitrate of the BGM files, seeing as my desired BGM works in a battle with a bug catcher, but not for a youngster, firebreather, cooltrainer, etc.
What bugs me more is that debug trainer battle works, so does when you use the change battle bgm command. what is even worse is that it happens with unedited Essentials script. (but it doesn't happen when I play the raw Essentials example game)
__________________
Sig in maintenance!
Reply With Quote
  #8    
Old November 10th, 2012, 09:49 PM
ambalance's Avatar
ambalance
Vorpal_Rabbit
 
Join Date: Apr 2008
Location: N/a
Gender:
Nature: Jolly
I thought maybe it might have something to do with my map sizes, seeing as I have large maps. I thought it might have something to do with lag, but it seems it doesn't. Still bugging me. I'm out of options!!
__________________
Signature:
Writer/Mapper/Eventing/Scripter/Spriter.

Also, writer.
Reply With Quote
  #9    
Old November 11th, 2012, 03:41 AM
~JV~'s Avatar
~JV~
Dev of Pokémon Uranium
 
Join Date: Aug 2007
Location: Rio de Janeiro
Age: 20
Nature: Relaxed
Send a message via Skype™ to ~JV~
I FOUND THE SOLUTION!

Find this line in PoemonUtilities:
Code:
 pbMEPlay(bgm)
Comment it and add this:
Code:
 Audio.bgm_play("Audio/ME/#{bgm.name}",bgm.volume,bgm.pitch)
There you go, it's fixed for good. pbMEPlay is just a bad method. For some reason it tends to f*** with what comes next (the battle bgm) because of unknow reasons that have to do with the trainer intro ME (which I noticed having some lag at the first time it plays). Audio.bgm_play was the one used the most in older versions of Essentials, and so far it has been way more realiable to me :)
__________________
Sig in maintenance!
Reply With Quote
  #10    
Old November 11th, 2012, 08:22 AM
ActionReplayer's Avatar
ActionReplayer
 
Join Date: Jun 2012
Gender: Male
Wait. So, you substituted
Quote:
pbMEPlay(bgm)
for
Quote:
Audio.bgm_play("Audio/ME/#{bgm.name}",bgm.volume,bgm.pitch)
or did you put the second one after the first?
Reply With Quote
  #11    
Old November 11th, 2012, 01:48 PM
~JV~'s Avatar
~JV~
Dev of Pokémon Uranium
 
Join Date: Aug 2007
Location: Rio de Janeiro
Age: 20
Nature: Relaxed
Send a message via Skype™ to ~JV~
Quote:
Originally Posted by ActionReplayer View Post
Wait. So, you substituted

for


or did you put the second one after the first?
substituted, however I added the "#" before it because I prefer to have original code commented
__________________
Sig in maintenance!
Reply With Quote
  #12    
Old November 18th, 2012, 02:02 AM
ambalance's Avatar
ambalance
Vorpal_Rabbit
 
Join Date: Apr 2008
Location: N/a
Gender:
Nature: Jolly
YES! That worked! Thanks so much. I'm glad it worked for you too.
__________________
Signature:
Writer/Mapper/Eventing/Scripter/Spriter.

Also, writer.
Reply With Quote
Reply
Quick Reply

Sponsored Links


Advertise here
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Minimum Characters Per Post: 25



All times are UTC -8. The time now is 02:24 PM.


Style by Nymphadora, artwork by Sa-Dui.
Like our Facebook Page Follow us on Twitter © 2002 - 2014 The PokéCommunity™, pokecommunity.com.
Pokémon characters and images belong to The Pokémon Company International and Nintendo. This website is in no way affiliated with or endorsed by Nintendo, Creatures, GAMEFREAK, The Pokémon Company or The Pokémon Company International. We just love Pokémon.
All forum styles, their images (unless noted otherwise) and site designs are © 2002 - 2014 The PokéCommunity / PokéCommunity.com.
PokéCommunity™ is a trademark of The PokéCommunity. All rights reserved. Sponsor advertisements do not imply our endorsement of that product or service. User generated content remains the property of its creator.