Go Back   The PokéCommunity Forums > ROM Hacking > ROM Hacking Hub

Notices
For all updates, view the main page.

ROM Hacking Hub General discussions about ROM Hacking and Emulation. Not sure where to start? This is the place for you.
Posting links to ROMs is illegal and is not tolerated anywhere on the forum.
New threads in this forum are to be approved by a moderator before they are displayed.



Reply
 
Thread Tools
  #1    
Old July 1st, 2007 (05:33 PM). Edited July 2nd, 2007 by Pazuzu.
Kiralio
Beginning Trainer
 
Join Date: Jun 2007
Gender:
Nature: Adamant
Something strange I've noticed - when I'm running Ruby or Sapphire in Rom form, movement in-game is perfectly smooth, with average speeds around 450-500% normal game and thirty frames per second - just about the right speed to make the game move right along without becoming uncontrollable. Also, turbo mode cranks this up to around 1000% normal speed and six frames per second, great for leveling against wild pokemon and other mindless tasks.

However, when I switch over to Emerald, the normal game speed is much lower - closer to 300 percent, and - here's the strange bit - running at 60 frames per second. As for turbo mode, it runs around 550-600, 6 frames per second, and 'lags' - the movement is jerky and doesn't actually seem that much faster.

I've kept all settings the same between the games; frameskip is set to 0, throttle is off, and VSync is also turned off, all being run at 640x480 resolution in-game and 1024x768 on my monitor. I could look up any of the other settings if someone thought they might be the reason, but I suspect these are the most relevant ones.

My computer is a 3.2 gigahertz Pentium 4 with a gig of ram, running Windows XP Professional with a Radeon X800 XT graphics card, and I'm running VisualBoy Advance version 1.72. My Pokemon Ruby rom is the United States version with the Mugs intro hack, my Emerald version is a generic one with no hacks that I know of.

Can anyone explain this to me, or tell me how I might work around it? I know it may seem like an insignificant difference, but the slowdown in Emerald from what I got well and used to is annoying enough that it makes the game less enjoyable than its two predecessors, despite the often handy or interesting extra features.

Alternatively, if there's a hack that alters the natural framerate of the rom (which seems like the most likely explanation, at least in my admittedly clueless best guess) could someone verify for me if a version of Pokemon Emerald with a similar hack exists? (I am NOT asking where it is, simply if it exists.)

Actually - a quick correction. Somewhere between switching games, I'd managed to set the frameskip to one. Both games run at sixty frames per second; however, even at the same frameskip, the problem is still pretty much as described. Emerald runs noticeable slower than Ruby or Sapphire, with all settings the same with the exception of the ROMs themselves.
Reply With Quote
Reply
Quick Reply

Sponsored Links
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Minimum Characters Per Post: 25



All times are UTC -8. The time now is 02:59 PM.