Conversation Between Urz and Delta231
1 to 12 of 12
  1. Urz
    May 29th, 2018 3:50 AM
    No worries,

    Thanks for helping.
  2. Delta231
    May 29th, 2018 3:47 AM
    I haven't made any patch.
  3. Urz
    May 29th, 2018 2:31 AM
    I'm Still having trouble inserting this into a clean FR rom. I'd like to do that before i repoint the functions to fit into my currently edited rom as I have used the space around b00000 already.

    I'm sorry to keep pestering you. Would you be able to insert your forked routine into a clean FR rom and send me the patch so I can compare it to my own and modify the offsets?

    I appreciate all the help you've gave me so far. If you have a paypal account, let me know your email and I will send some money your way for your troubles :)
  4. Delta231
    May 28th, 2018 7:19 PM
    That code is bit modified inorder to make it compatible with Dynamic Pallete Patch
  5. Urz
    May 28th, 2018 2:00 PM
    Sorry to bother you again.

    After checking the compiled file after I ran it through Hackmews Thumb.bat.

    The compiled .bin file seems very strange and unlike anything I have seen before.

    The hex shows the bytes 'A8 00 2A 50 repeated many times and doesnt seem to match up at all with the original asm made by Shiny Quagsire (I'm checking using the patch made by Nisarg)

    I think i'm missing something stupid so if you could point me in the right direction I'd appreciate it.

    I've attached the asm and the bin file to this link below if you could take a look?!AtfEPlaaDBPRinTRLm4v71ROJ8DQ
  6. Urz
    May 28th, 2018 6:50 AM
    Perfect. This worked.

    You're very kind. Many thanks for your help.
  7. Delta231
    May 28th, 2018 12:08 AM
    The file must be extracted inside the folder containing the assembler arm-none-eabi-gcc.
    Then simply drag your * .C file to the BATCH file.
    Alternatively, once you have arrived in the folder containing the assembler arm-none-eabi-gcc, write the command "casm nomefile.c" in the prompt and press the "ENTER" key.
    The ASM files will then be assembled through the hackmew BATCH.
    Once the code is assembled, you should see a message like this:

    "filename" successfully assembled!
    Press a button to continue. . .
  8. Urz
    May 27th, 2018 7:42 AM
    Can confirm that no file is produced anywhere :(

    Would you be able to upload and link me to the bin file that you have produced so I can use that? I don't know how or where to start on fixing this otherwise.

    If you could then I'd be extremely grateful :)
  9. Delta231
    May 27th, 2018 4:31 AM
    A .bin file should be produced
  10. Urz
    May 27th, 2018 3:55 AM
    Thank you for getting back to me.

    Whenever I drag the npcmod.c to the casm.bat the cmd window flashes and disappears without doing anything. No output file is produced (I believe a file.asm file should be produced?)

    I'm not sure if it's my computer setup that is causing this not to work. I'm running windows 10.

    Just to make sure, the download link only came with one file - the casm.bat file correct?

    If I'm doing anything wrong then I'd be grateful if you pointed me in the right direction on how to get this to work. I'm fine with the asm insertion. Just new to C :-)
  11. Delta231
    May 26th, 2018 8:50 PM
    Hmmm, I have compiled the npcmod.c file with that. How is it not working?
  12. Urz
    May 26th, 2018 11:22 AM
    Hi, I hope you can help me.

    Do you have a compiled version of the NPCmod.c file from Shiny Quagsires DN system?. I have tried using the CASM.bat file you linked to in this thread below

    But it's not working when I drag the .c file onto the batch file. Could you help?