Advertiser Content
Anthroyd's Profile Picture

Anthroyd

Visitor Messages

1 to 15 of 43
  1. Child Amnesiac
    2 Weeks Ago 4:42 PM
    Child Amnesiac
    Hey, can we talk?

    I don't know if you remember me, but I remember you, and I remember what happened all those months ago back on Youtube.

    I would just like to say that I was completely in the wrong there, and I honestly don't think I deserve to be forgiven for my actions. But if you would like to forgive me, please do.

    But if you wish me any form of ill will, I would be completely content, because I know I deserve it.
  2. Rooouge
    July 10th, 2019 1:26 AM
    Rooouge
    Update: I've downloaded again the Fire Red ROM to test on a fresh and clear ROM. Same problem: person event works but not regular script. Now I think I've just skipped an extra step on XSE, A-Map or somewhere else that a normal script requires...
  3. Rooouge
    July 7th, 2019 12:43 PM
    Rooouge
    Hi Anthroyd, I'm asking your help cause I'm stuck on my hack rom scripts (I've also left a comment on your tutorial on YouTube, ep. 13, my nick is Rouje)

    My huge problem is that regular scripts (those displayed on Advance Map with the 'S') don't work as they should, instead person event scripts (those with 'P' on A-Map) work perfectly.
    I've made a lot of tests in these days, even with simple and basic scripts like these one I've posted on pastebin:

    - Person Event Script (P) : https://pastebin.com/M46jZADt
    - Regular Script (S) : https://pastebin.com/PB5XeYEU

    As I said before, the person event works fine, so no problem on it.
    Even if it's identical at the person event (except for "faceplayer") the regular script doesn't work. What happens is that when I step on the square with the script, this starts it's execution but it stops at "lock" instruction. The player can't move but the game is still running because music still going as normal.
    I've made also a test without the "lock" instruction. The result is that the game load the msgbox offset but again nothing is happening, the music still going and the player can't move again.

    Any idea to fix this strange problem?
  4. Zankew
    May 8th, 2019 6:00 AM
    Zankew
    i guess i will have to use the small trees for the border blocks(or place enough trees but i dont like that idea much because a lot of space will be taken up) which is surely gonna look ugly if the player goes to the extreme sides of the map.
    anyway, thanks for the reply tho
  5. Zankew
    May 6th, 2019 10:39 AM
    Zankew
    Hey anthroyd!
    Your tutorials are of great help
    But i got a problem. My trees are of 9x9 blocks instead of the normal 6x6 blocks in fire red. I cannot understand how to use those trees in the border blocks as there is only 4 blocks space. Will i have to change all of the trees and insert a 6x6 block tree?
  6. Phantom_Rairak
    March 10th, 2019 9:24 PM
    Phantom_Rairak
    Nevermind, actually...I was able to figure it out. All I had to do was assign it a variable number and it worked perfectly. I guess all scripts have to have a variable number, even if they're supposed to activate all the time huh?
  7. Phantom_Rairak
    March 10th, 2019 9:01 PM
    Phantom_Rairak
    Hi Anthroyd, I have a question about hacking Pokemon Emerald. I'm following along in your Mobility tutorial on Youtube- number 11- and I'm having issues. I was able to find out that instead of 0x113 and 0x114 for the camera's special values, I had to use 0x116 and 0x117, but even more so, the script still doesn't function. No script I create functions for that matter- only when tied to a Person Event in Advanced Map. Script Events softlock the game. Any help? Thank you!
  8. Hunterrosabelle
    December 29th, 2018 5:48 AM
    Hunterrosabelle
    Hi Anthroyd,

    Thanks for making the tutorial on overworld sprite management - it was really informative and it helped to de-mystify many aspects of overworld sprite replacement for me. I have a quick question: I've been trying to insert new sprites into Pokemon Ruby ROM by following the steps in your tutorial. However, instead of using dynamic palette slots 0x0 and 0xA, I chose to use the other static slots such as 0x2, 0x3 instead, because certain sprites share the same palette (although the palettes used by the new sprites are different from that from the original Pokemon Ruby palettes). I loaded the correct palette IDs into the respective palette slots. However, when I test the sprites in-game, they appear glitched, suggesting that the static palette slots (0x2, 0x3 etc) don't seem to be referencing the right palette IDs. Any idea why this could be so? Would very much appreciate any help. Thanks again in advance!
  9. DrFuji
    December 22nd, 2018 1:02 AM
    DrFuji
    An artist is always their own worst critic~

    Can I get a refund if I don't like it?
  10. DrFuji
    December 21st, 2018 6:16 PM
    DrFuji
    No worries man, I'd glad that the tutorial was of help! :D

    I really enjoyed your youtube tutorial series. Even if the video weren't for somebody of my hacking level, I thought you were concise/ well-spoken and they were really good for people just learning to hack for the first time. If you ever feel like starting it back up again some time in the future, I'd be happy to help out with one or two videos if you'd like.

    Thanks for the compliment on Lilac! Coincidentally, I've got a week off work coming up and was thinking about playing Pokemon Dreary as you updated it a few days ago. I'll post in your thread with my thoughts on it when I've played it~
  11. Alan Flygon
    June 18th, 2018 8:21 AM
    Alan Flygon
    Anthroyd bro,
    See my first post- https://www.pokecommunity.com/showthread.php?t=409753
    Please give a reply about how you liked it, in the post
  12. Alan Flygon
    May 9th, 2018 3:30 AM
    Alan Flygon
    Anthroyd bro,
    can you write me a simple elevator script?
    which has to be inserted in Signpost event

    And there is a good news and bad news
    >good news is that now the player sprite is not appearing
    >and bad news is that my messed up sprite is appearing
    i hope i will figure it out soon!

    I tried what you said about inserting ingame sprites and it worked without any problem!
  13. Alan Flygon
    May 6th, 2018 10:23 PM
    Alan Flygon
    OK thanks Anthroyd,
    I need one more help from you
    Can you give the link for downloading the Hxd and the Licence tool that you said about in your tutorial because I can't open firered ROM in Over world manager it says "It is not Lz " so no tables are appearing.
  14. Alan Flygon
    May 5th, 2018 11:10 PM
    Alan Flygon
    Hi Anthroyd
    I said that ''the player's sprite is standing at the place of my new sprite."
    "I meant that after using Overworld Manager and inserting my sprite to the game in position 255, I opened Advance map and placed my Palette messed sprite in LITTLERROOT TOWN and saved the rom. But when I opened that rom in VBA, insted of my messed up sprite the "player's sprite" is standing in the place of my messed up sprite"
    This is what I tried to tell you!
    Here is the link of imgur.com in which I posted the images of my sprite messing up
    https://imgur.com/a/Me3i7Wq
    Please kindly help me with the problem
  15. Alan Flygon
    May 4th, 2018 8:58 AM
    Alan Flygon
    Hi Anthroyd,
    I am a new hacker, I am 15 years old. I just started a few weeks ago and I am learning with the help of your ROM Hacking Tutorial.
    I finished till Tutorial 24 part I, But when I was adding my own sprite-
    I added in Emerald Rom with Overworld Manager, It is a type 1 with 9 sheets.
    I successfully saved it to the ROM.
    Then when I opened it in Advance Map its whole pallete just changed but I decreased colour depth to 16 colours with the Infranview, So I don't know what happened! And when I opened my ROM the player's sprite is standing at the place of my new sprite
    So plz HELP
    I don't know how to post the image in this conversation that's why I am not posting it, if you tell me how to post from my PC plz tell then I will show you in the picture what happened!
    If you know what happened plz post it on my visitor message or in my gmail- flamercoc0@gmail.com

About Me

Statistics

Total Posts
Activity by Forum
Visitor Messages
Blog
General Information
  • Last Activity: 6 Hours Ago 7:30 PM
  • Join Date: May 17th, 2016
  • Referrals: 3