View Single Post
  #283    
Old January 18th, 2009 (9:08 AM). Edited January 18th, 2009 by TMASTER1.
TMASTER1 TMASTER1 is offline
     
    Join Date: Jan 2009
    Gender:
    Posts: 3
    I have a slight problem with a script I've made. It's for a hack of FireRed.
    Code:
    #org $ begin
    lock
    faceplayer
    message $poke
    $poke 1 = \v\h01, long time, no see.\nPROF.ELM asked me to find you.\pHe has another favor to ask.
    boxset 6
    message $poke1
    $poke1 1 = Would you take the Pokémon Egg?
    boxset 5
    compare LASTRESULT 1
    if 1 goto $get
    message $toobad
    $toobad 1 = B-but... PROF.ELM asked for you...
    boxset 6
    release
    end
    
    #org $get
    lock
    message $get1
    $get1 1 = \v\h01 received EGG.
    boxset 6
    #raw 0x7A 0xAF 0x00
    message $received
    $received 1 = We discovered that a POKéMON will not\nhatch until it grows in the EGG.\pIt also has to be with other active\nPOKéMON to hatch.\p\v\h01, you're the only person\nwe can rely on.\pPlease return to ELM's LAB when that\nEGG hatches!
    boxset 6
    applymovement 0x05 $move
    pausemove 0
    release
    end
    
    #org $move
    #raw 0x12 
    #raw 0x10 
    #raw 0x10 
    #raw 0x10
    #raw 0x10
    #raw 0x60 
    #raw 0xFE
    The person I've tried to make move just won't move. Everything else works in the script. He just won't move for some reason. I've even tried switching the 0x05 to 0xFF to make sure that it wasn't the fact that I had the wrong person selected but the player didn't move as well. Does anyone know what I'm doing wrong? Someone suggested that the lock might be a problem so I moved the release above the applymovement and the person moved but then when I went to give him 2 more movements (the #raw 0x10 and the #raw 0x60) he didn't do those 2, he just does the first 4 and then stops. Also the person will move back to where he originally was after I reload that map. Is there a way to make him stay disappeared?
    Thanks in advance.
    EDIT
    I've figured out my problems, no need for help.