View Single Post
Old January 18th, 2009 (10:40 AM).
TB Pro's Avatar
TB Pro TB Pro is offline
    Join Date: Nov 2004
    Location: Midwestern USA
    Age: 23
    Gender: Male
    Posts: 2,739
    Originally Posted by Esmas View Post
    Alright, I've gotten a weird reaction from my ROM. When I inserted a simple XSE message script for a NPC (I've inserted them before, mind you) in my Ruby hack, it didn't work. I hit the A button (which is my space bar), and it continued walking around, as if the script was never inserted. It looks like the script was even compiled correctly.

    Then, I inserted the script into a clean Ruby ROM, and it worked. I tried everything I can; copied exactly the statistics of that sprite, etc. This is the script I used, though I don't think there's anything wrong with it...

    #Dynamic 0x800000

    #org @talk
    msgbox @talk2 0x2

    #org @talk2
    = This is a message script test.
    Have you tried decompiling it? That's happened to me before, and there was nothing on the script just #ORG @blah then release and end. Also, was the NPC already there? Or did you add him? If he was already there, try removing him, and adding a new NPC. Also, try adding lock, boxset 2 only does faceplayer

    Originally Posted by Lukeyjohnno View Post
    Have you tried adding a LockPlayer script?
    There is no such thing as a lockplayer script, or a command for that matter. There is lock, which locks the NPC's. There's lockall, which locks everything including the player, and the camera.
    --I'm a creepin'..