View Single Post
Old March 5th, 2010 (3:34 PM). Edited March 5th, 2010 by PeregrineFig.
PeregrineFig's Avatar
PeregrineFig PeregrineFig is offline
Starting Pokémon Obsidian
    Join Date: Feb 2010
    Location: Michigan, USA
    Age: 23
    Gender: Male
    Nature: Hardy
    Posts: 202
    I'm having an annoying issue with hex editing anything. I attempted to edit the intro of FireRed using the original method in the first post. I found the old text, highlighted it all and deleted it, then translated my new text into the hex code on notepad, copied it, and used Paste special, picked CF_TEXT, and checked interpret as hexadecimal string. Everything looked right, so I saved and opened my ROM. I got nothing but a white screen, nothing would load. I backed up my ROM and tried again, same result. Eventually that hack got scrapped because I made a blunder and broke some important stuff, but anyway, I tried editing Birch's intro in Emerald for a new hack. I only changed 2 words, but I used the same method of deleting and pasting. Again, blank white screen. This is incredibly frustrating, am I doing something wrong with my method of hex insertion? I'd really like to know how to fix this. If anyone will help me out here, then thank you.

    Edit: After experimentation I'm convinced I'm just doing something wrong here. I tested this again and just replaced a single character, and instead of deleting/pasting, I typed the new hex value over the old one, and everything worked fine. My new issue is, how can I add a character? If the new hex I enter in has the same amount of characters as the old, it runs properly. But if it has more or less, it just breaks my ROM.
    Reply With Quote