View Single Post
Old February 11th, 2013 (7:13 AM). Edited February 11th, 2013 by karatekid552.
karatekid552's Avatar
karatekid552 karatekid552 is offline
What happens if I push it?....
    Join Date: Nov 2012
    Location: Do you really want to know? Really?
    Gender: Male
    Nature: Bold
    Posts: 1,766
    Originally Posted by QuartierGenerale View Post
    Here i am again.

    Strange thing: playing my hack rom (VBALink 1.8) i noticed how the top-left box with name of entering city does not appear when i enter in a new map...

    I've checked AM (1.95), but in every map the 0.1 (Show name) is setted.

    What's the problem?

    Thanks a lot


    I've setted for i don't known why the 4000 flag...without it all work fine
    Flags above the 8FF are stored overlapping variables 4000+. So by setting flag 4000 you interrupted some other data, which by my calculations is var 4370. This var is probably involved in showing the location upon entering the map.

    Originally Posted by Robbi View Post
    First off, I am new to this hacking. Secondly, it is an Emerald hack.

    I have made the first town, with the same events as Little root, to see how things will go and all that jazz. I also made the route above it(to the right of it now) and moved around and changed the events on that. I also made a cave that links the two together.

    Just ask for the pictures if you want to know what they look like, since I cannot post pictures yet.
    That is what i have. So here are my problems i am facing.

    1)When I start, I start in the water a few squares above the left house. The events play as normal, so this is okay for now.

    2) The cave, I can go inside, but I cannot leave through any of the exists, I have tried different movement permissions, events, etc, but I don't know what to do.

    3)On the route, since i stopped working on the warp part, i wanted to see if the event worked for getting your starter pokemon. So i made a small connection as you can see in the picture. But when i step somewhere i get locked onto a text script saying "this is a test script. This is a signpost script." Or something along the lines of that.

    If any of y'all know anything, that would be great. Thanks.
    1) a little program called SMCA will help you.

    2)for cave exits where the doorway is facing up (meaning you walk down to get out) the tile just above the door way needs have warp capabilities in its behavior, and the warp needs to be placed on it. There are two floor tiles that look the same. One is just your standard floor tile while the second has warp properties.

    For emerald, the block (tile) # for a normal cave floor in title set 19 is block 201. The block # for a warp tile is block 207. If you want to see how this works or to check for other warp-able blocks, open up the block editor and look at its behavior data.

    Block numbers can be found in the bottom lefthand corner of Amap when you hover over a particular block.

    3) I can't see a picture, and that is because you need 15 posts to post pictures. My best guess is that there is green-s-tile on the ground in the events tab where you stepped. Delete it.

    Good luck and welcome to the rom hacking forum.

    Paired with Simba