View Single Post
Old April 17th, 2013 (12:05 AM). Edited April 17th, 2013 by lemonzap.
lemonzap's Avatar
lemonzap lemonzap is offline
the 1337 lemonmeister
    Join Date: Aug 2012
    Gender: Male
    Posts: 6
    Originally Posted by Shadowraze View Post
    Yes you didn't 0x on 900000. It should be 0x900000

    And also you didn't put a closeonkeypress command after the msgbox command but if you don't want to put that change 0x4 to 0x6. Also put a release and end to @yes and @no.

    Oh and also didn't you said you were using an S tile? You have to put a variable in it. Try reading this tut I'm sure it will help you.

    Just put a setvar in the end of your script so for example setvar 0x4075 0x1 and then on A-map put in 4075 on the Var Number and it should work.
    I moved the people who were being told to move closer and now that works but still no messages show up. I changed the message types to 0x6 and added a setvar but it didnt change anything. I've read through that tutorial before but have not been able to find any information on the s-tiles in there so I've just been trying things out. Also I don't know if this could be related but when I try to make a level script that displays a message it just displays

    This is a test message
    this is a signpost

    over and over again. Everything else in the level script works fine, just not messages. just like my s-tile script.

    Thanks for the help. I really appreciate the speedy reply.

    I've been trying to make more scripts and I have not been able to make a message display yet. I have even tried copying example scripts directly from tajaros' tutorial and using them in both emerald and fire red. I cant figure out what I'm doing wrong.

    I finally fixed my problem. I had to add


    after each message. for instance this would not work

    msgbox @wait 0x6

    but this does work

    msgbox @wait 0x6
    boxset 6