Thread: [Tutorial] In depth Advance Map tutorial
View Single Post
  #470    
Old November 15th, 2013 (3:03 PM).
jatomlinson jatomlinson is offline
     
    Join Date: Nov 2011
    Gender: Female
    Posts: 26
    I've been playing around in Advance Map and XSE trying to hack and I have a lot of questions because things don't seem to be working right. I'm hacking Fire Red.

    1) I have a grasp of Warps, and have gotten most of them to work correctly on the town I'm making. However, I have an issue with one of the warps coming out of one of the houses. In Advance map when I click 'follow' to follow the warp out to the town, it works just fine, and when I click follow to go back into the house, it works fine. I've double and triple checked and the map bank/warp numbers all match up. When I go into the game to test it however, and I walk out of the house, it takes me to some strange room that looks like a battle room and there's a lady waiting in there. If you stick around it tries to pair you with a big black square instead of a pokemon and gives you a big black square for your pokemon. If you walk out of this room it takes you back to the house. What's gone wrong?

    2) How do I set the starting house that the player will appear in when you first start the game, and can I set it to appear somewhere on the town map instead of inside a house? How do I do this?

    3) I'm having trouble with people events I add to the map. I add a little girl sprite up at the top of the map somewhere and script her, set the movement to 0. When I go into the game, she's not where I put her, she's down somewhere near the bottom of the map. Doesn't seem to matter where I move her to, she's determined to appear at the same spot towards the bottom of the map. Secondly, when I talk to her, she says the script I put into XSE but says it all jumbled together. For instance if I write a line that says: "What are you looking at me like that for?" and then the next line is: "Are you going to steal from me?"
    It comes out like this: "What are you looking at me like are you going to steal?" And then it will bring up the next line and say: "going to steal like that for?"
    I double and triple check this in XSE and it appears to have rearranged itself after I script it. It's frustrating.

    3) I had put another person event into place, scripted him, and when I went to talk to him in game the entire screen went black. I could still hear the music, but there was no way to get out of the black screen except to restart. Does anyone know why this happened?

    I'm a total noob, and apologies in advance for all the questions. As a side note, I tried using two other scripting programs first before using XSE because the other ones looked easier to use. I tried using Advance Text but when I went to load the ROM and clicked on the hacked ROM it opened up like the base ROM not the one I'd hacked and changed the village name and appearance. I tried several times and even downloaded a different version of Advance Text and nada. Couldn't get it to load. Anyone know how to fix that?

    Thanks!
    Reply With Quote