Pokémon Essentials All questions and discussion about Pokémon Essentials, the Pokémon game kit for RPG Maker XP, go in here. Also contains links to the latest downloads and the Essentials Wiki.

Reply
 
Thread Tools
  #576    
Old January 25th, 2014 (10:31 AM).
Radical Raptr's Avatar
Radical Raptr Radical Raptr is offline
#BAMFPokemonNerd
     
    Join Date: Mar 2011
    Location: everywhere
    Age: 22
    Gender: Male
    Nature: Sassy
    Posts: 1,120
    Quote:
    Originally Posted by WackyTurtle View Post
    I'm also having this issue, and it's preventing me from releasing a demo. How do I fix this?
    link
    __________________

    ~My Deviantart - Litharreon Wiki - Litharreon Game Download~

    Reply With Quote

    Relevant Advertising!

      #577    
    Old February 1st, 2014 (3:11 AM).
    Tao's Avatar
    Tao Tao is offline
       
      Join Date: Jan 2009
      Posts: 5
      In version 12 in the Bug Contest the buttons "Pokémon" and "Ball" were reversed, this was changed in version 13, but now nothing happens when you click on Ball, it just count down the amount of Sport Balls.
      I've looked in the scripts, but the PokemonBugContest script wasn't changed, so i can't find out what to do.
      Can someone tell me how to repair this?
      Reply With Quote
        #578    
      Old February 21st, 2014 (9:28 PM).
      Joltik's Avatar
      Joltik Joltik is offline
         
        Join Date: Jan 2010
        Gender: Male
        Nature: Modest
        Posts: 116
        In the Safari Zone, when you start any safari battle, the game crashes (a problem related to mega evolutions, it seems)

        Code:
        Message: undefined method `isMega?' for #<PokeBattle_FakeBattler:0x98aa5f0>
        PokeBattle_ActualScene:748:in `refresh'
        PokeBattle_ActualScene:651:in `initialize'
        PokeBattle_ActualScene:1886:in `new'
        PokeBattle_ActualScene:1886:in `pbStartBattle'
        PokeBattle_SafariZone:101:in `pbStartBattle'
        PokemonSafari:114:in `pbSafariBattle'
        PokemonSafari:113:in `pbSceneStandby'
        PokemonSafari:115:in `pbSafariBattle'
        PokemonSafari:112:in `pbBattleAnimation'
        PokemonSafari:112:in `pbSafariBattle'
        __________________

        Check out my DeviantArt account! My game project is called Pokemon Subrosia.
        My DeviantArt | Old DeviantArt
        Reply With Quote
          #579    
        Old February 24th, 2014 (3:23 PM). Edited February 24th, 2014 by Joltik.
        Joltik's Avatar
        Joltik Joltik is offline
           
          Join Date: Jan 2010
          Gender: Male
          Nature: Modest
          Posts: 116
          When crossing a bridge, running pbBridgeOff makes every bridge tile (terrain tag 15) become transparent, which is really weird.

          EDIT: The situation with the bridges is not as general as I previously reported. The problem only happens when one of the dimensions of the map is greater than 100 tiles.

          I used route 2 as an exemple. The problem doesnt happen there, unless you increase the map's height to a value greater than 100 (120 in my exemple).



          Attached Thumbnails
          scheme.png‎   problem.png‎  
          __________________

          Check out my DeviantArt account! My game project is called Pokemon Subrosia.
          My DeviantArt | Old DeviantArt
          Reply With Quote
            #580    
          Old February 24th, 2014 (3:28 PM).
          Maruno's Avatar
          Maruno Maruno is offline
          Lead Dev of Pokémon Essentials
             
            Join Date: Jan 2008
            Location: England
            Posts: 5,173
            Quote:
            Originally Posted by Giu View Post
            When crossing a bridge, running pbBridgeOff makes every bridge tile (terrain tag 15) become transparent, which is really weird.
            Can you provide screenshots of this?
            __________________
            Go to the Pokémon Essentials Wiki

            | Downloads | Tutorials | Fangames |
            | All Animations Project |

            Follow me on Twitter: @maruno42


            Reply With Quote
              #581    
            Old February 24th, 2014 (5:43 PM).
            Joltik's Avatar
            Joltik Joltik is offline
               
              Join Date: Jan 2010
              Gender: Male
              Nature: Modest
              Posts: 116
              Quote:
              Originally Posted by Maruno View Post
              Can you provide screenshots of this?
              Sure, I'll edit my last post and add more details.
              __________________

              Check out my DeviantArt account! My game project is called Pokemon Subrosia.
              My DeviantArt | Old DeviantArt
              Reply With Quote
                #582    
              Old February 24th, 2014 (8:45 PM).
              BlackWaltz3's Avatar
              BlackWaltz3 BlackWaltz3 is offline
                 
                Join Date: Jul 2009
                Gender: Male
                Posts: 188
                I've noticed that if I set a trainertype's pre-battle ME in the PBS file, and the battle begins while the ME is still playing, Essentials will stop playback of the ME and fail to load the battle BGM. This occurs both with midis and mp3s/wavs. If the ME is allowed to play all the way through before the battle begins, such that the regular BGM resumes playing, things will proceed as expected.

                I'm not really sure why this occurs, but I can say for sure that it kind of defeats the purpose of having an encounter ME if it stops other music from playing unless it finishes first. Any suggestions?
                Reply With Quote
                  #583    
                Old February 26th, 2014 (1:21 PM).
                tImE's Avatar
                tImE tImE is offline
                It's still me, 44tim44 ;)
                   
                  Join Date: Mar 2007
                  Location: Somewhere in Scandinavia...
                  Nature: Relaxed
                  Posts: 685
                  Quote:
                  Originally Posted by jim42 View Post
                  I've noticed that if I set a trainertype's pre-battle ME in the PBS file, and the battle begins while the ME is still playing, Essentials will stop playback of the ME and fail to load the battle BGM. This occurs both with midis and mp3s/wavs. If the ME is allowed to play all the way through before the battle begins, such that the regular BGM resumes playing, things will proceed as expected.

                  I'm not really sure why this occurs, but I can say for sure that it kind of defeats the purpose of having an encounter ME if it stops other music from playing unless it finishes first. Any suggestions?
                  I am using PE v13 and I am using pre-battle ME's just fine.
                  It must be a problem on your end.
                  __________________
                  Reply With Quote
                    #584    
                  Old February 27th, 2014 (12:25 AM).
                  BlackWaltz3's Avatar
                  BlackWaltz3 BlackWaltz3 is offline
                     
                    Join Date: Jul 2009
                    Gender: Male
                    Posts: 188
                    It occurs in a clean Essentials build as well, FWIW. There's a chance I've done it incorrectly but I don't believe there much opportunity to do so. It should simply be a matter of inserting a string equal to the filename of an ME into the seventh field and then recompiling, no? The rest should be handled by the pbTrainerIntro based on that data.
                    Reply With Quote
                      #585    
                    Old February 27th, 2014 (12:43 AM).
                    tImE's Avatar
                    tImE tImE is offline
                    It's still me, 44tim44 ;)
                       
                      Join Date: Mar 2007
                      Location: Somewhere in Scandinavia...
                      Nature: Relaxed
                      Posts: 685
                      Yeah, but in that case, why do I not have the problem?
                      I assume you have tried staring a new save-file, as well?
                      __________________
                      Reply With Quote
                        #586    
                      Old February 27th, 2014 (1:51 AM).
                      BlackWaltz3's Avatar
                      BlackWaltz3 BlackWaltz3 is offline
                         
                        Join Date: Jul 2009
                        Gender: Male
                        Posts: 188
                        Yes, I did. Starting a new file had no effect. I wonder if it is related to the unusually long time it takes to load audio at random times. This often occurs the first time an audio file is played after beginning execution. I had thought this might have been just my computer performing poorly, but now with this second issue...
                        Reply With Quote
                          #587    
                        Old February 27th, 2014 (4:44 AM).
                        Radical Raptr's Avatar
                        Radical Raptr Radical Raptr is offline
                        #BAMFPokemonNerd
                           
                          Join Date: Mar 2011
                          Location: everywhere
                          Age: 22
                          Gender: Male
                          Nature: Sassy
                          Posts: 1,120
                          Quote:
                          Originally Posted by jim42 View Post
                          Yes, I did. Starting a new file had no effect. I wonder if it is related to the unusually long time it takes to load audio at random times. This often occurs the first time an audio file is played after beginning execution. I had thought this might have been just my computer performing poorly, but now with this second issue...
                          I have only had the music take a longtime to load when I'm using midi's, but mp3's seem to work fine - I also thought I was the only one to have that problem
                          __________________

                          ~My Deviantart - Litharreon Wiki - Litharreon Game Download~

                          Reply With Quote
                            #588    
                          Old February 27th, 2014 (10:14 AM).
                          tImE's Avatar
                          tImE tImE is offline
                          It's still me, 44tim44 ;)
                             
                            Join Date: Mar 2007
                            Location: Somewhere in Scandinavia...
                            Nature: Relaxed
                            Posts: 685
                            Which type of audio-files are the ME-files and the battle theme you are using?
                            __________________
                            Reply With Quote
                              #589    
                            Old February 27th, 2014 (3:39 PM).
                            BlackWaltz3's Avatar
                            BlackWaltz3 BlackWaltz3 is offline
                               
                              Join Date: Jul 2009
                              Gender: Male
                              Posts: 188
                              The battle themes are all midis, and the MEs I've tested include both midis and mp3s/wavs. Also, I'll note that the aforementioned 'long time to load' problem hangs the game while occuring, so I know the missing battle BGM isn't loading at all as opposed to just still loading.
                              Reply With Quote
                                #590    
                              Old February 28th, 2014 (12:47 AM).
                              tImE's Avatar
                              tImE tImE is offline
                              It's still me, 44tim44 ;)
                                 
                                Join Date: Mar 2007
                                Location: Somewhere in Scandinavia...
                                Nature: Relaxed
                                Posts: 685
                                Well, I am using MP3's for all my music, so that might be it.

                                Try substituting your BGM and Intro-ME with placeholder music in mp3 format, and see if that works.
                                __________________
                                Reply With Quote
                                  #591    
                                Old February 28th, 2014 (7:36 PM).
                                BlackWaltz3's Avatar
                                BlackWaltz3 BlackWaltz3 is offline
                                   
                                  Join Date: Jul 2009
                                  Gender: Male
                                  Posts: 188
                                  Hmm, quite curious. I did as you said and substituted the map BGM, intro ME, and battle BGM with three different mp3 files and all functioned correctly. Furthermore, there wasn't so much as a single second of lag or hang time when they were played. It sounds to me like either Essentials or RMXP itself has a problem handling midi files.
                                  Reply With Quote
                                    #592    
                                  Old March 1st, 2014 (5:19 AM).
                                  Maruno's Avatar
                                  Maruno Maruno is offline
                                  Lead Dev of Pokémon Essentials
                                     
                                    Join Date: Jan 2008
                                    Location: England
                                    Posts: 5,173
                                    It's Windows 7 (and presumably 8), actually, that can't deal with midi. As far as I understand it, they no longer have native support for midi files, so they have to "render" the whole midi file before they can play them. This takes time.

                                    Wav is the quickest audio format to use, but obviously it's also the biggest in file size.
                                    __________________
                                    Go to the Pokémon Essentials Wiki

                                    | Downloads | Tutorials | Fangames |
                                    | All Animations Project |

                                    Follow me on Twitter: @maruno42


                                    Reply With Quote
                                      #593    
                                    Old March 1st, 2014 (8:26 AM).
                                    BlackWaltz3's Avatar
                                    BlackWaltz3 BlackWaltz3 is offline
                                       
                                      Join Date: Jul 2009
                                      Gender: Male
                                      Posts: 188
                                      Hmm, that's quite interesting. I hadn't even considered that that could be a problem, much less that it would be. I guess it's time to figure out some mp3/wav replacement files. Thanks for pointing that out, Maruno.
                                      Reply With Quote
                                        #594    
                                      Old March 1st, 2014 (8:35 AM).
                                      tImE's Avatar
                                      tImE tImE is offline
                                      It's still me, 44tim44 ;)
                                         
                                        Join Date: Mar 2007
                                        Location: Somewhere in Scandinavia...
                                        Nature: Relaxed
                                        Posts: 685
                                        Off-Topic, but while we're still on the topic of soundfiles:
                                        Whenever an mp3 file is loaded (when I transfer to, enter an area or an event starts it) a weird snap or static sound is played, before the actual song or sound starts for me.
                                        Is this a problem with Essentials, RMXP or Windows, and is it fixable? Also, does the same happen to .wav files?
                                        __________________
                                        Reply With Quote
                                          #595    
                                        Old March 5th, 2014 (2:25 PM).
                                        dexter1o6 dexter1o6 is offline
                                           
                                          Join Date: Jul 2013
                                          Age: 29
                                          Gender: Male
                                          Posts: 64
                                          Quote:
                                          Originally Posted by tImE View Post
                                          Enemy Spearow's sprite disappears when it uses Aerial Ace. Not sure if this bug affect every enemy that uses Aerial Ace or if it's only Spearow, just happened to notice it when testing my game.

                                          EDIT: It reappeared during the following round, after being hit by my attack.

                                          Not sure if it matters, but the first move I used was Dragon Rage, when it disappeared, and Ember when it reappeared. I was using a Charmeleon
                                          I found this same problem too. When the opponent uses Aerial Ace with a Heracross, the Heracross disappears from the screen. If the Heracross moves first, the attack of my Ralts/Combusken/Whismur (tried several times) is skipped (although Whismur fainted before being able to attack). Ralts fainted from one of the second Aerial Ace, and disappeared as well (right before fainting).

                                          Because I didn't see this answered yet, I decided to post it again. I did my own research: I did not find Aerial Ace in the code (in a place other than just a list [compiler: def pbTMRS, around line 1528; PokemonOrgBattleGenerator: def addMove, around line 47]), and Aerial Ace seems to work using it myself with a Poochyena (debuged it to the poor fellow). Thus, I suspect the problem to lie within the animation (there is a separate animation for the opponent), but I did not find a solution. I am not so familiar (yet) with creating/adjusting animations. Any help?

                                          Regards,

                                          dexter1o6
                                          Reply With Quote
                                            #596    
                                          Old March 5th, 2014 (5:42 PM). Edited March 5th, 2014 by Mike'n'Ike.
                                          Mike'n'Ike's Avatar
                                          Mike'n'Ike Mike'n'Ike is offline
                                             
                                            Join Date: Apr 2013
                                            Gender: Male
                                            Posts: 10
                                            Quote:
                                            Originally Posted by Ratty524 View Post
                                            Has anyone had weird errors with the animation pack that is currently included in v13? For some animations, such as defense curl and harden, the animation cels appear at the upper left hand corner of the screen as oppose to center when playtesting both my game and another fangame that I recently picked up. Other animations like growl or sand-attack don't seem to leave the center of the allied battler, and instead clump together weirdly.

                                            What's weird about this is that when I play each default animation in the editor, they work perfectly, and every cel appears at the right position.
                                            Quote:
                                            Originally Posted by desbrina View Post
                                            i'm having the same thing with the animations, from what i've seen its mainly those that change stats, though i've also noticed the opponent version of sand attack points upwards not downwards
                                            This is the same problem I've noticed, yet while playing through Pokemon Zeta, he seems to have all his move effects aligned properly, agility works well same with smokescreen and string shot!
                                            Currently I believe string shot animation appears on the pokemon using it and the rest are shot somewhere off to the top left. Does anyone know or can direct me to the bug fix, assuming there is one since in Zeta it works fine
                                            Reply With Quote
                                              #597    
                                            Old March 6th, 2014 (12:20 PM).
                                            Ratty524's Avatar
                                            Ratty524 Ratty524 is offline
                                               
                                              Join Date: Jan 2011
                                              Gender: Male
                                              Nature: Calm
                                              Posts: 303
                                              Quote:
                                              Originally Posted by Mike'n'Ike View Post
                                              This is the same problem I've noticed, yet while playing through Pokemon Zeta, he seems to have all his move effects aligned properly, agility works well same with smokescreen and string shot!
                                              Currently I believe string shot animation appears on the pokemon using it and the rest are shot somewhere off to the top left. Does anyone know or can direct me to the bug fix, assuming there is one since in Zeta it works fine
                                              I don't know a bug fix, but I imagine that if you export the default animation, delete it, then re-import it back in to essentials it might work fine, since I think it's a problem only with the default animations.

                                              I haven't tested this, though.
                                              Reply With Quote
                                                #598    
                                              Old March 9th, 2014 (4:49 PM). Edited March 9th, 2014 by The Detonator.
                                              The Detonator The Detonator is offline
                                                 
                                                Join Date: Mar 2014
                                                Gender: Male
                                                Posts: 3
                                                Hello! Just joined here. I apologize if this has already been asked but I can't find the search tool for this thread.

                                                I just started making a new game with Essentials today and have encountered a problem. After I select one of my starter Pokemon the game tells me I have received the Pokemon, then the poke ball disappears.

                                                The problem arises when I open the menu and attempt to look at my party by clicking the "Pokemon" button on the menu. I receive this error:

                                                ---------------------------
                                                Pokemon Essentials
                                                ---------------------------
                                                Exception: RuntimeError

                                                Message: filename is nil

                                                SpriteWindow:218:in `initialize'

                                                PokemonSprite:113:in `new'

                                                PokemonSprite:113:in `pokemon='

                                                PokemonSprite:99:in `initialize'

                                                PokemonParty:341:in `new'

                                                PokemonParty:341:in `initialize'

                                                PokemonParty:614:in `new'

                                                PokemonParty:614:in `pbStartScene'

                                                PokemonParty:612:in `each'

                                                PokemonParty:612:in `pbStartScene'



                                                This exception was logged in

                                                C:\Users\David\Saved Games/Pokemon Essentials/errorlog.txt.

                                                Press Ctrl+C to copy this message to the clipboard.
                                                ---------------------------
                                                OK
                                                ---------------------------


                                                Thanks for reading this, and hope you guys can help me!
                                                Reply With Quote
                                                  #599    
                                                Old March 9th, 2014 (5:53 PM).
                                                Skystrike's Avatar
                                                Skystrike Skystrike is offline
                                                • Silver Tier
                                                 
                                                Join Date: Sep 2008
                                                Location: internet
                                                Gender: Male
                                                Nature: Quiet
                                                Posts: 1,533
                                                Quote:
                                                Originally Posted by The Detonator View Post
                                                Hello! Just joined here. I apologize if this has already been asked but I can't find the search tool for this thread.

                                                I just started making a new game with Essentials today and have encountered a problem. After I select one of my starter Pokemon the game tells me I have received the Pokemon, then the poke ball disappears.

                                                The problem arises when I open the menu and attempt to look at my party by clicking the "Pokemon" button on the menu. I receive this error:

                                                ---------------------------
                                                Pokemon Essentials
                                                ---------------------------
                                                Exception: RuntimeError

                                                Message: filename is nil

                                                SpriteWindow:218:in `initialize'

                                                PokemonSprite:113:in `new'

                                                PokemonSprite:113:in `pokemon='

                                                PokemonSprite:99:in `initialize'

                                                PokemonParty:341:in `new'

                                                PokemonParty:341:in `initialize'

                                                PokemonParty:614:in `new'

                                                PokemonParty:614:in `pbStartScene'

                                                PokemonParty:612:in `each'

                                                PokemonParty:612:in `pbStartScene'



                                                This exception was logged in

                                                C:\Users\David\Saved Games/Pokemon Essentials/errorlog.txt.

                                                Press Ctrl+C to copy this message to the clipboard.
                                                ---------------------------
                                                OK
                                                ---------------------------


                                                Thanks for reading this, and hope you guys can help me!
                                                Did you download the Pokemon pack v1? It has the Pokemon graphics, and you don't, that's why you're getting that error.
                                                __________________

                                                I lack toast and am tolerant
                                                Reply With Quote
                                                  #600    
                                                Old March 10th, 2014 (12:07 PM).
                                                The Detonator The Detonator is offline
                                                   
                                                  Join Date: Mar 2014
                                                  Gender: Male
                                                  Posts: 3
                                                  Quote:
                                                  Originally Posted by Akaran View Post
                                                  Did you download the Pokemon pack v1? It has the Pokemon graphics, and you don't, that's why you're getting that error.
                                                  Oh thanks! I saw that when I was downloading it, but not sure if I needed it! Is there a specific folder I need to put that into? Like the graphics...etc.?



                                                  Also I am extremely new to this (Just started yesterday). Are there any video tutorials that can help me learn, or any tutorials in general? I used this: (Edit: Apparently not allowed to post links....His you tube username is Atomic Reactor, he made Pokemon obsidian) to get me started, but wanted to know if there were others out there? Any other sources besides the wikia?
                                                  Reply With Quote
                                                  Reply
                                                  Quick Reply

                                                  Sponsored Links
                                                  Thread Tools

                                                  Posting Rules
                                                  You may not post new threads
                                                  You may not post replies
                                                  You may not post attachments
                                                  You may not edit your posts

                                                  BB code is On
                                                  Smilies are On
                                                  [IMG] code is On
                                                  HTML code is Off

                                                  Forum Jump


                                                  All times are GMT -8. The time now is 8:12 AM.