The PokéCommunity Forums Fan Games ROM Hacking
[ARCHIVE] Simple Questions (SEARCH BEFORE ASKING A QUESTION)

ROM Hacking Need a helping hand? You can get help on any ROM Hacking-related problems or questions you have here.

Closed Thread
 
Thread Tools
  #27426    
Old November 30th, 2013 (2:42 AM).
leyn09's Avatar
leyn09 leyn09 is offline
Truant Trainer
     
    Join Date: May 2011
    Location: Philippines
    Gender: Male
    Nature: Careful
    Posts: 84
    Quote:
    Originally Posted by Mirai Kuriyama View Post
    You can change the type on Hex editor. I recommend you use HxD.
    Also, you can take the tutorial. There's for Ruby and FireRed on the tut section.
    As for your first question, I have no knowledge to that :(
    Will do. Thanks for answering. :3
      #27427    
    Old November 30th, 2013 (3:43 AM).
    GreyVirgo's Avatar
    GreyVirgo GreyVirgo is offline
    •=ØInfinityØ=•
       
      Join Date: Oct 2013
      Location: With Miley...... Twerking!
      Gender: Male
      Nature: Serious
      Posts: 227
      Quote:
      Originally Posted by exidia View Post
      Is it possible to edit the chances of encountering shiny Pokémon? If so, how?
      (Ruby)
      Yes, It is possible..... With the use of Shinyzer (I think..... I never used that tool before) but if I'm not mistaken it should be in the Toolbox.... If you can't find it then search in WAH's Pokemon hacking tools page. :)
      __________________
      Pair: Saturnus

      Other Forums Im In:

      EGC Account: Grey
      PHO Account: XLR8
      LV Account: Grey

      Contact: PM or VM

      "I love making out with lamps!" - Nigahiga
        #27428    
      Old November 30th, 2013 (4:30 AM).
      dusktrickster dusktrickster is offline
         
        Join Date: Nov 2013
        Gender: Male
        Posts: 7
        condition switch help
        Ok so first off wanna say i looked all over for help and couldn't find anything.
        The thing i am trying to do is when you walk into the players house a Controlling event kinda like when you walk into professor oak and you walk up to him i want that but instead walks up to mom know i have had 2 results

        first: I get frozen and cant move

        second it works but every time i walk into the house it dose it not just a 1 time thing

        please help
          #27429    
        Old November 30th, 2013 (5:05 AM).
        giggity69 giggity69 is offline
           
          Join Date: Nov 2013
          Gender: Male
          Posts: 1
          I downloaded an emulator and pokemon Emerald. I want to transfer my pokémon caught in the ROM to my legit Pokemon White game. If I took the .pkm file from the ROM and uploaded it to pokedit where I can send it to my pokemon white game using GTS, would I be able to use this pokémon in random matchup or in tournaments? The only cheats I use on the Emerald ROM are event cheats like the Eon ticket. I know they are not actually legit but would I be able to use them online and possibly migrate to pokemon x and y when pokemon bank and transfer is released?
            #27430    
          Old November 30th, 2013 (5:10 AM).
          rastin1990 rastin1990 is offline
             
            Join Date: Apr 2012
            Gender: Male
            Posts: 4
            hello everyone.

            can someone please tell me
            where to get pokemon bw pokedex order.

            thanks
              #27431    
            Old November 30th, 2013 (5:14 AM).
            MylittlePlusle's Avatar
            MylittlePlusle MylittlePlusle is offline
               
              Join Date: Nov 2013
              Gender: Male
              Posts: 37
              I don't know if this is in the right section but I have a problem with BWTE...

              When I try to edit Corless' battle (The one in the frigate) it shows that he only has 1 Pokemon instead of 5, what do I do to fix this?
                #27432    
              Old November 30th, 2013 (6:37 AM).
              Sniper's Avatar
              Sniper Sniper is offline
              ふゆかい
                 
                Join Date: Nov 2013
                Location: Philippines
                Gender: Male
                Nature: Quiet
                Posts: 1,448
                Quote:
                Originally Posted by dusktrickster View Post
                condition switch help
                Ok so first off wanna say i looked all over for help and couldn't find anything.
                The thing i am trying to do is when you walk into the players house a Controlling event kinda like when you walk into professor oak and you walk up to him i want that but instead walks up to mom know i have had 2 results

                first: I get frozen and cant move

                second it works but every time i walk into the house it dose it not just a 1 time thing

                please help
                It froze? Try changing the var number to 4050 then unknown to 0300.
                Quote:
                Originally Posted by dusktrickster View Post
                second it works but every time i walk into the house it dose it not just a 1 time thing
                I don't get it. Could you post your script here. So that I could read it. and see what's wrong.
                __________________


                  #27433    
                Old November 30th, 2013 (7:05 AM). Edited November 30th, 2013 by karatekid552.
                MylittlePlusle's Avatar
                MylittlePlusle MylittlePlusle is offline
                   
                  Join Date: Nov 2013
                  Gender: Male
                  Posts: 37
                  I'm trying to hack Black 2, I'm using BWTE, everything works fine expect for...

                  Colress - 581

                  When I try to edit it...
                  Spoiler:


                  That happens, what do I do?
                    #27434    
                  Old November 30th, 2013 (9:43 AM).
                  ep!c ep!c is offline
                  Banned
                     
                    Join Date: Mar 2013
                    Gender: Male
                    Posts: 124
                    Quote:
                    Originally Posted by dusktrickster View Post
                    condition switch help
                    Ok so first off wanna say i looked all over for help and couldn't find anything.
                    The thing i am trying to do is when you walk into the players house a Controlling event kinda like when you walk into professor oak and you walk up to him i want that but instead walks up to mom know i have had 2 results

                    first: I get frozen and cant move

                    second it works but every time i walk into the house it dose it not just a 1 time thing

                    please help
                    Well, are you using AM 1.92 for map-scripts?
                    Map-scripts usually bug hard in AM 1.92, in 1.95 they are almost bugfree.
                    You also need a variable, that is free and safe to use (4000-4050 if im correct..)
                    In the script, you set this variable to 1. ;)

                    @MylittlePlusle
                    I dont really know wheres the problem..

                    But by the way, remove the "TuneUp" from your PC, its useless and just eats RAM.. xD
                    If you need more speed buy a new PC, the optimation by these 100 tools in the internet are
                    0,00000000001 % ^^
                      #27435    
                    Old November 30th, 2013 (11:34 AM).
                    Maglor's Avatar
                    Maglor Maglor is offline
                       
                      Join Date: Apr 2013
                      Gender: Male
                      Posts: 63
                      I've been searching, but it is pretty difficult to word this issue. Atleast according to my search results.


                      In my Fire Red ROM Hack in progress, Houndour (have not tested other pokemon) starts evolving at level 24 (as it should). Halfway trough the progress, it stops, and gives me the message ".....?". This happens also the second time he tries to evolve. I've checked YAPES, which states he is to be Houndoom at level 24, so I guess that's not the problem.
                      Anyone encountered this before?
                        #27436    
                      Old November 30th, 2013 (11:44 AM).
                      Renegade's Avatar
                      Renegade Renegade is offline
                      Time for real life...
                         
                        Join Date: Nov 2011
                        Location: United States
                        Gender: Male
                        Nature: Careful
                        Posts: 998
                        Quote:
                        Originally Posted by Maglor View Post
                        I've been searching, but it is pretty difficult to word this issue. Atleast according to my search results.


                        In my Fire Red ROM Hack in progress, Houndour (have not tested other pokemon) starts evolving at level 24 (as it should). Halfway trough the progress, it stops, and gives me the message ".....?". This happens also the second time he tries to evolve. I've checked YAPES, which states he is to be Houndoom at level 24, so I guess that's not the problem.
                        Anyone encountered this before?
                        You have to give the player the National Dex in order for other-region Pokemon to evolve.
                          #27437    
                        Old November 30th, 2013 (12:10 PM).
                        FrozenInfernoZX's Avatar
                        FrozenInfernoZX FrozenInfernoZX is offline
                        What is out there?
                           
                          Join Date: Jun 2012
                          Location: United States
                          Gender: Male
                          Nature: Adamant
                          Posts: 770
                          Quote:
                          Originally Posted by CrystalStatic View Post
                          You have to give the player the National Dex in order for other-region Pokemon to evolve.
                          About that, I have created a custom regional dex of 247 Pokemon. I have used a tool called "Misc Editor" in order to fix the evolution thing since the game still recognizes the region to be limited up to 151 even though my region dex is 247. Mybe the reason why the program didn't fix my problem could be because I haven't changed some more limiters regarding the Pokedex? I changed three limiters. I am still missing some because the Pokemon menu still display Pokemon after 151 as ??? even though they are registered in the Pokedex as number 221 for instance.
                          ----------
                          Also, does anybody know why for some tracks inserted into Sappy play perfectly fine, but in-game there are those random beeps while it is playing? This only happens for some tracks.
                          __________________

                          Current Live Update: Build 3.0 RC 2.73 No more Flag Errors!
                          Always periodically make backup saves!
                            #27438    
                          Old November 30th, 2013 (12:10 PM).
                          Maglor's Avatar
                          Maglor Maglor is offline
                             
                            Join Date: Apr 2013
                            Gender: Male
                            Posts: 63
                            Quote:
                            Originally Posted by CrystalStatic View Post
                            You have to give the player the National Dex in order for other-region Pokemon to evolve.
                            Ah. Peculiar. Anyways, thank you very much.
                              #27439    
                            Old November 30th, 2013 (2:03 PM).
                            Kawaii Shoujo Duskull's Avatar
                            Kawaii Shoujo Duskull Kawaii Shoujo Duskull is offline
                            The Cutest Duskull
                               
                              Join Date: Jul 2013
                              Location: Far too deep in my thoughts.
                              Age: 22
                              Gender: Female
                              Nature: Timid
                              Posts: 279
                              Okay, I have a question about looping songs for GBA roms using Anvil Studio.

                              If I recall correctly, the process went like this:
                              - Create a song
                              - go into the piano roll editer
                              - Move to the end of where you want your loop and place a ] using the "new cue" button
                              - Move to the beginning of where you want the song to loop and place a [
                              - Save and convert to a .s file for use with Sappy.
                              (That's how I understood the tutorial anyway)

                              When I assemble the song with sappy, it doesn't change it at all. No looping in sappy or ingame--it only plays once.

                              So my question is, am I doing anything wrong here, and if so, what? Or is this something else?

                              Thanks for any help in advance.
                                #27440    
                              Old November 30th, 2013 (4:37 PM).
                              chrunch chrunch is offline
                               
                              Join Date: Oct 2009
                              Gender: Male
                              Posts: 1,350
                              Anyone have an answer for this?

                              It could be very helpful to me, just want to make sure there won't be any side-effects of doing it.
                              __________________
                                #27441    
                              Old November 30th, 2013 (4:54 PM).
                              kearnseyboy6's Avatar
                              kearnseyboy6 kearnseyboy6 is offline
                              Aussie's Toughest Mudder
                                 
                                Join Date: Dec 2008
                                Posts: 300
                                Quote:
                                Originally Posted by Merak View Post
                                Okay, I have a question about looping songs for GBA roms using Anvil Studio.

                                If I recall correctly, the process went like this:
                                - Create a song
                                - go into the piano roll editer
                                - Move to the end of where you want your loop and place a ] using the "new cue" button
                                - Move to the beginning of where you want the song to loop and place a [
                                - Save and convert to a .s file for use with Sappy.
                                (That's how I understood the tutorial anyway)

                                When I assemble the song with sappy, it doesn't change it at all. No looping in sappy or ingame--it only plays once.

                                So my question is, am I doing anything wrong here, and if so, what? Or is this something else?

                                Thanks for any help in advance.
                                YES!! I am fairly sure it is because you are saving! File> Export Midi 0 format (or something like that).

                                It does make the difference, I had that problem!

                                Now I have a question about IPS patching. Say I make changes in a 'clean' ROM that uses space from C00000-D00000 and I patch this to 'JPANS engine' ROM. This patch will overwrite the data from C00000-D00000 but will it also patch the 'clean ROM' area from 000000-300000? I hope that make sense.
                                __________________
                                HOLIDAYING CURRENTLY!!
                                  #27442    
                                Old November 30th, 2013 (6:07 PM).
                                Kawaii Shoujo Duskull's Avatar
                                Kawaii Shoujo Duskull Kawaii Shoujo Duskull is offline
                                The Cutest Duskull
                                   
                                  Join Date: Jul 2013
                                  Location: Far too deep in my thoughts.
                                  Age: 22
                                  Gender: Female
                                  Nature: Timid
                                  Posts: 279
                                  Quote:
                                  Originally Posted by kearnseyboy6 View Post
                                  YES!! I am fairly sure it is because you are saving! File> Export Midi 0 format (or something like that).

                                  It does make the difference, I had that problem!

                                  Now I have a question about IPS patching. Say I make changes in a 'clean' ROM that uses space from C00000-D00000 and I patch this to 'JPANS engine' ROM. This patch will overwrite the data from C00000-D00000 but will it also patch the 'clean ROM' area from 000000-300000? I hope that make sense.
                                  I think I tried and failed to get results exporting as midi format0 but meh another shot wouldn't really hurt. :) Thanks for letting me know about that.

                                  And about your question, sorry but I don't have an answer for that. All I can say is experiment. ^^
                                    #27443    
                                  Old November 30th, 2013 (6:12 PM).
                                  Eren Jaeger's Avatar
                                  Eren Jaeger Eren Jaeger is offline
                                  Pianoist
                                     
                                    Join Date: Apr 2013
                                    Location: EARTH
                                    Gender: Male
                                    Nature: Serious
                                    Posts: 155
                                    Quote:
                                    Originally Posted by Merak View Post
                                    I think I tried and failed to get results exporting as midi format0 but meh another shot wouldn't really hurt. :) Thanks for letting me know about that.

                                    And about your question, sorry but I don't have an answer for that. All I can say is experiment. ^^
                                    You should have put this "]" in the end of the midi. (Should be correct if not it won't work)
                                    Then place the "[" where you want. Then export the midi, it should work fine.
                                    __________________
                                    Music is art
                                      #27444    
                                    Old November 30th, 2013 (8:46 PM).
                                    Le pug's Avatar
                                    Le pug Le pug is offline
                                    Creator of Pokémon: Discovery / Fat Kid
                                     
                                    Join Date: Aug 2013
                                    Location: Le bed
                                    Age: 25
                                    Gender: Male
                                    Nature: Bold
                                    Posts: 869
                                    in advancemap the tiles look dandy and in the block list they look fine and there is no behavior or background bytes in the tiles i made so there should be no problem. im using palettes 7, 10, and 6 so there should be no issue and this is the first time this has happened in the emulator they look like messed up blocks or they'll have the water animation to them most tiles are working its only certain tiles that are messed up if i create the tile in a new block, the tiles still look screwy in the emulator

                                    __________________




                                    /// Pokémon: Discovery
                                    /// Pokémon: Fat Kid
                                    /// Tile Insertion Tutorial For AdvanceMap
                                    /// Pokémon Emerald Specials Resource Thread
                                    /// Pokémon Emerald Decapitalization Patch
                                    /// Emerald Titlescreen Cloud Removal Tutorial
                                    /// Tutorial For Fixing Any ROM-related Bug
                                      #27445    
                                    Old November 30th, 2013 (9:09 PM).
                                    karatekid552's Avatar
                                    karatekid552 karatekid552 is offline
                                    What happens if I push it?....
                                       
                                      Join Date: Nov 2012
                                      Location: Do you really want to know? Really?
                                      Gender: Male
                                      Nature: Bold
                                      Posts: 1,766
                                      Quote:
                                      Originally Posted by Le pug View Post
                                      in advancemap the tiles look dandy and in the block list they look fine and there is no behavior or background bytes in the tiles i made so there should be no problem. im using palettes 7, 10, and 6 so there should be no issue and this is the first time this has happened in the emulator they look like messed up blocks or they'll have the water animation to them most tiles are working its only certain tiles that are messed up if i create the tile in a new block, the tiles still look screwy in the emulator

                                      It is the position in the tileset, not the block set, that is causing the issues. When water is loaded, or any animation for that matter, all of it's frames are stored in the empty spaces in you tilesets, in the ram. If you replace those spaces, the animation will still happen, overwriting your new tiles. This is what happened to you. The most common thing that happens to people like this is having the door animation show up like you have water showing up.
                                      __________________

                                      Paired with Simba
                                        #27446    
                                      Old November 30th, 2013 (9:45 PM).
                                      Le pug's Avatar
                                      Le pug Le pug is offline
                                      Creator of Pokémon: Discovery / Fat Kid
                                       
                                      Join Date: Aug 2013
                                      Location: Le bed
                                      Age: 25
                                      Gender: Male
                                      Nature: Bold
                                      Posts: 869
                                      Quote:
                                      Originally Posted by karatekid552 View Post
                                      It is the position in the tileset, not the block set, that is causing the issues. When water is loaded, or any animation for that matter, all of it's frames are stored in the empty spaces in you tilesets, in the ram. If you replace those spaces, the animation will still happen, overwriting your new tiles. This is what happened to you. The most common thing that happens to people like this is having the door animation show up like you have water showing up.

                                      I see what you mean, I used ruby tileset 11 which is the entrance to the elite four which has a lot of flower tiles. How would I go about fixing this? Would I have to use a different tileset because this one can not be changed or is this gonna require some sort of hex number changing stuff?
                                      __________________




                                      /// Pokémon: Discovery
                                      /// Pokémon: Fat Kid
                                      /// Tile Insertion Tutorial For AdvanceMap
                                      /// Pokémon Emerald Specials Resource Thread
                                      /// Pokémon Emerald Decapitalization Patch
                                      /// Emerald Titlescreen Cloud Removal Tutorial
                                      /// Tutorial For Fixing Any ROM-related Bug
                                        #27447    
                                      Old November 30th, 2013 (11:13 PM).
                                      Sniper's Avatar
                                      Sniper Sniper is offline
                                      ふゆかい
                                         
                                        Join Date: Nov 2013
                                        Location: Philippines
                                        Gender: Male
                                        Nature: Quiet
                                        Posts: 1,448
                                        Can I have two mugshot show at one script?
                                        By using showpokepic two times? Can they show both at a time?
                                        __________________


                                          #27448    
                                        Old December 1st, 2013 (12:46 AM).
                                        DrFuji's Avatar
                                        DrFuji DrFuji is offline
                                        Heiki Hecchara‌‌
                                         
                                        Join Date: Sep 2009
                                        Location: Aussie
                                        Age: 25
                                        Gender: Male
                                        Nature: Jolly
                                        Posts: 1,438
                                        Quote:
                                        Originally Posted by chrunch View Post
                                        Anyone have an answer for this?

                                        It could be very helpful to me, just want to make sure there won't be any side-effects of doing it.
                                        Its been a while since I've worked with OW palettes, but from what I recall it should be fine. The only complication is that palettes 0 and 16 load into the same palette slot so you would need to change palette 16 to a different slot. If you don't do this then your palettes will overwrite each other when an OW with palette 16 appears on-screen as it conflicts with the player's OW.

                                        Make a back up before doing anything, as like I said, its been a while since I've messed with OWs :P

                                        Quote:
                                        Originally Posted by Mirai Kuriyama View Post
                                        Can I have two mugshot show at one script?
                                        By using showpokepic two times? Can they show both at a time?
                                        Nope, the games can only support one active showpokepic at a time. You can use two different pictures in the same script but they can't be on screen together.
                                        __________________
                                          #27449    
                                        Old December 1st, 2013 (1:08 AM).
                                        chrunch chrunch is offline
                                         
                                        Join Date: Oct 2009
                                        Gender: Male
                                        Posts: 1,350
                                        Whenever I use a nickname script it only nicknames the first Pokemon in my party. How could I make it nickname the Pokemon that I just got given?
                                        __________________
                                          #27450    
                                        Old December 1st, 2013 (1:42 AM).
                                        DrFuji's Avatar
                                        DrFuji DrFuji is offline
                                        Heiki Hecchara‌‌
                                         
                                        Join Date: Sep 2009
                                        Location: Aussie
                                        Age: 25
                                        Gender: Male
                                        Nature: Jolly
                                        Posts: 1,438
                                        Quote:
                                        Originally Posted by chrunch View Post
                                        Whenever I use a nickname script it only nicknames the first Pokemon in my party. How could I make it nickname the Pokemon that I just got given?
                                        The Pokemon which is nicknamed is determined by the value of the 0x8004 variable. If you want to automatically nickname the last Pokemon in your party then you can do something like this:

                                        Code:
                                        ...
                                        countpokemon
                                        copyvar 0x8004 0x800D
                                        subvar 0x8004 0x1
                                        fadescreen 0x1
                                        special 0x9E
                                        ...
                                        You need to subtract one from 0x8004 since the value 0x0 = your first Pokemon, 0x1 = second etc.
                                        __________________
                                        Closed Thread

                                        Quick Reply

                                        Join the conversation!

                                        Create an account to post a reply in this thread, participate in other discussions, and more!

                                        Create a PokéCommunity Account
                                        Thread Tools

                                        Posting Rules
                                        You may not post new threads
                                        You may not post replies
                                        You may not post attachments
                                        You may not edit your posts

                                        BB code is On
                                        Smilies are On
                                        [IMG] code is On
                                        HTML code is Off

                                        Forum Jump


                                        All times are GMT -8. The time now is 10:23 AM.