Advertiser Content

Map Sprite Appearing in Map Connection

Started by concusstimized October 6th, 2019 12:39 PM
  • 516 views
  • 4 replies
Seen 1 Day Ago
Posted 1 Week Ago
20 posts
150 Days
Hello, everyone. I have an annoying little problem in my current project. I completely gutted the events in Viridian City and changed the maps for everything. It's all working fine, except for a little remnant.



As you can see in the image, there is a sprite popping up in the fenceline. There is no event there. And the sprite only appears when entering south to Viridian from route 2. I THINK that it's in the same location as the tree that you would cut down in the normal fire red. If you refresh the map from the other direction, it clears.

As an extra little hiccup, it originally showed up as the main character sprite and somehow changed to a painter sprite later on.

Anyone have any idea why this is reacting this way? Any tips on removing it? I'm hoping I don't need to clear the whole map and start from scratch, but at this point, I feel like I have to.

UPDATE: I remade the map entirely and the same issue is still occurring. So now I'm really at a loss.
Online now
Posted 11 Hours Ago
322 posts
11.5 Years
Hello, everyone. I have an annoying little problem in my current project. I completely gutted the events in Viridian City and changed the maps for everything. It's all working fine, except for a little remnant.



As you can see in the image, there is a sprite popping up in the fenceline. There is no event there. And the sprite only appears when entering south to Viridian from route 2. I THINK that it's in the same location as the tree that you would cut down in the normal fire red. If you refresh the map from the other direction, it clears.

As an extra little hiccup, it originally showed up as the main character sprite and somehow changed to a painter sprite later on.

Anyone have any idea why this is reacting this way? Any tips on removing it? I'm hoping I don't need to clear the whole map and start from scratch, but at this point, I feel like I have to.

UPDATE: I remade the map entirely and the same issue is still occurring. So now I'm really at a loss.
Check for the movesprite and movesprite2 commands in the level scripts (and delete them if you wish to). Also makes sure to check all person events of both viridian city and route 2.
Online now
Posted 11 Hours Ago
322 posts
11.5 Years
I already deleted the level scripts, and the only person events are those that I made. I had wiped the events of both maps prior to setting up the rest.
There can also be person events that don't appear visible on the map in AdvanceMap because their X and Y coordinates are past the border of the map.

Make sure to check person event 6 of Route 2 in AdvanceMap and I'm pretty sure that will fix your problem;)
Advertiser Content