Research & Development Got a well-founded knack with ROM hacking? Love reverse-engineering the Pokémon games? Or perhaps you love your assembly language. This is the spot for polling and gathering your ideas, and then implementing them! Share your hypothesis, get ideas from others, and collaborate to create!

Draconius GO
Reply
 
Thread Tools
  #26    
Old May 5th, 2017 (1:37 PM).
AtecainCorp.'s Avatar
AtecainCorp. AtecainCorp. is online now
Rejishan awake...
     
    Join Date: Jun 2008
    Location: Takoabe Town (Region Thonsu)
    Age: 24
    Gender: Male
    Nature: Hardy
    Posts: 1,270
    Quote:
    Originally Posted by Spherical Ice View Post
    This is for FireRed, not Ruby.
    But someone put here RUBY port of this hack. And even with that port things do not work. In my case is script for Reveal Mirror since I've make formes of "Forces of Nature"
    __________________
    - My new Project comming Soon
    Reply With Quote

    Relevant Advertising!

      #27    
    Old July 15th, 2017 (2:08 PM). Edited August 2nd, 2017 by Lunos.
    Lunos's Avatar
    Lunos Lunos is offline
    Uruguayan Random Guy
       
      Join Date: Oct 2008
      Posts: 1,054
      Quote:
      Originally Posted by kleenexfeu View Post
      I tested it (on emerald) and it works
      I know it's been a lot of time since that post, but I remembered it and decided to come and ask for help.
      I don't quite understand what exactly is failing.

      What I'm trying to do is to attach jiangzhengwenjz's EV/IV Screen for Emerald onto my Theta Emerald EX ROM for personal use.
      I inserted the routine from the main post at E1ABB0
      Changed "XX XX XX" to "EF 04 80" since 8004EF is where I've inserted the script that would allow me to activate the EV/IV Screen.
      I already configured the Item that I want to use for this accordingly too (Index 34 because it comes after the Green Shard, Use-of-SELECT and the field usage on Item Manager is "8E1ABB1").
      I left all the files from jiang's code by default, so the callasm 0x8F90001 should work perfectly on my ROM.
      This is the script I've attached to the item
      And finally, this is the result:


      Halp..? ;_; ....

      EDIT: Fixed, Phenom's routine does work.
      __________________
      Reply With Quote
      Reply

      Quick Reply

      Join the conversation!

      Create an account to post a reply in this thread, participate in other discussions, and more!

      Create a PokéCommunity Account

      Sponsored Links
      Thread Tools

      Posting Rules
      You may not post new threads
      You may not post replies
      You may not post attachments
      You may not edit your posts

      BB code is On
      Smilies are On
      [IMG] code is On
      HTML code is Off

      Forum Jump


      All times are GMT -8. The time now is 11:34 PM.