ROM Hacking Need a helping hand? You can get help on any ROM Hacking-related problems or questions you have here.

Closed Thread
 
Thread Tools
  #25551    
Old June 14th, 2013 (9:43 AM).
Hacker Bisharp's Avatar
Hacker Bisharp Hacker Bisharp is offline
Bug reporter
     
    Join Date: Dec 2011
    Gender: Male
    Nature: Gentle
    Posts: 334
    Quote:
    Originally Posted by gogojjtech View Post
    Flight spots are the orange F's in advance map. They show where you land when you use fly. Putting on in front of a pc makes you fly there.
    Hmm, well... and how can i add another in a specific map?
    __________________
    Hacks I support:

    And i'm a good bug reporter. Contact me if you want :D


    Relevant Advertising!

      #25552    
    Old June 14th, 2013 (10:39 AM).
    Spherical Ice's Avatar
    Spherical Ice Spherical Ice is offline
    • Moderator
    • Silver Tier
     
    Join Date: Nov 2007
    Location: Bristol, UK
    Age: 19
    Posts: 5,200
    Quote:
    Originally Posted by Hacker Bisharp View Post
    Hmm, well... and how can i add another in a specific map?
    Did you know?
    ...that the PokéCommunity forums come bundled with their very own Search function? It makes looking for the right thread or post super easy, and it's real easy to use!
    This message was brought to you by the PokéCommunity Forums!

    http://www.pokecommunity.com/showthread.php?t=206197
    __________________

    A Pokemon that is discriminated!
    Support squirtle and make it everyone's favourite.
      #25553    
    Old June 14th, 2013 (6:06 PM).
    Renegade's Avatar
    Renegade Renegade is offline
    Time for real life...
       
      Join Date: Nov 2011
      Location: United States
      Gender: Male
      Nature: Careful
      Posts: 998
      Okay, this is getting very irritating. Whenever I use the command "hidesprite 0xX" in XSE, it never works. This problem starting occuring fairly recently, so it's not XSE's fault. It worked perfectly for a while, then just died on me. I have everything set up the correct way, it just... isn't working. Any ideas?

      (Just a thing, I tried re-installing XSE to make sure and it still isn't working. Could this be the ROM's fault?)
      __________________
        #25554    
      Old June 14th, 2013 (6:34 PM).
      BlackWhiteRobin's Avatar
      BlackWhiteRobin BlackWhiteRobin is offline
         
        Join Date: Sep 2012
        Age: 19
        Gender: Male
        Nature: Quirky
        Posts: 537
        Quote:
        Originally Posted by CrystalStatic View Post
        Okay, this is getting very irritating. Whenever I use the command "hidesprite 0xX" in XSE, it never works. This problem starting occuring fairly recently, so it's not XSE's fault. It worked perfectly for a while, then just died on me. I have everything set up the correct way, it just... isn't working. Any ideas?

        (Just a thing, I tried re-installing XSE to make sure and it still isn't working. Could this be the ROM's fault?)
        Well, it depends. Did you follow the setflag 0xXXX and set it to a Person's Event No.?
        __________________

          #25555    
        Old June 14th, 2013 (6:40 PM).
        Renegade's Avatar
        Renegade Renegade is offline
        Time for real life...
           
          Join Date: Nov 2011
          Location: United States
          Gender: Male
          Nature: Careful
          Posts: 998
          Quote:
          Originally Posted by robin22gongon View Post
          Well, it depends. Did you follow the setflag 0xXXX and set it to a Person's Event No.?
          Everything is set up properly.
            #25556    
          Old June 14th, 2013 (6:46 PM).
          BlackWhiteRobin's Avatar
          BlackWhiteRobin BlackWhiteRobin is offline
             
            Join Date: Sep 2012
            Age: 19
            Gender: Male
            Nature: Quirky
            Posts: 537
            Quote:
            Originally Posted by CrystalStatic View Post
            Everything is set up properly.
            Was your ROM somewhat clean before you did it?

            Try compiling your script on a clean ROM and see if it works.
            __________________

              #25557    
            Old June 14th, 2013 (7:00 PM).
            karatekid552's Avatar
            karatekid552 karatekid552 is offline
            What happens if I push it?....
               
              Join Date: Nov 2012
              Location: Do you really want to know? Really?
              Gender: Male
              Nature: Bold
              Posts: 1,766
              Quote:
              Originally Posted by CrystalStatic View Post
              Okay, this is getting very irritating. Whenever I use the command "hidesprite 0xX" in XSE, it never works. This problem starting occuring fairly recently, so it's not XSE's fault. It worked perfectly for a while, then just died on me. I have everything set up the correct way, it just... isn't working. Any ideas?

              (Just a thing, I tried re-installing XSE to make sure and it still isn't working. Could this be the ROM's fault?)
              There is always the possiblility you corrupted the routine, but that would more than likely cause crashing. I think it applys to how you are using the command in the script. Could you show us a complete example of one that won't work?
              __________________

              Paired with Simba
                #25558    
              Old June 14th, 2013 (7:16 PM).
              Renegade's Avatar
              Renegade Renegade is offline
              Time for real life...
                 
                Join Date: Nov 2011
                Location: United States
                Gender: Male
                Nature: Careful
                Posts: 998
                Quote:
                Originally Posted by karatekid552 View Post
                There is always the possiblility you corrupted the routine, but that would more than likely cause crashing. I think it applys to how you are using the command in the script. Could you show us a complete example of one that won't work?
                Here it is:
                Code:
                #dynamic 0x800000
                
                #org @start
                hidesprite 0x6
                setflag 0x903
                release
                end
                It doesn't really matter which script I show you, though. A lot of the scripts in my hack have the hidesprite command and work. If I go back to them and edit them IN ANY WAY, the hidesprite command will stop working for no reason... Seems like my ROM has problems for some reason.
                  #25559    
                Old June 14th, 2013 (7:23 PM).
                GoGoJJTech's Avatar
                GoGoJJTech GoGoJJTech is offline
                (☞゚ヮ゚)☞ http://GoGoJJTech.com ☜(゚ヮ゚☜)
                • Gold Tier
                 
                Join Date: Nov 2012
                Location: Earth
                Age: 18
                Gender: Female
                Nature: Jolly
                Posts: 2,477
                Hidesprite and showsprite only work on level scripts, but movesprite and movesprite2 work all the time. Remember that.
                __________________
                I believe in Jesus Christ my Savior. If you do too, and aren't scared to admit it, then copy and paste this into your signature.
                The HGSS Music Patch - The BW/2 Music Patch - ASM: Switch Music Based on Seasons
                Romhack.me Profile - Pokecommunity Profile - Youtube Channel

                Support me at my site!
                Pokémon Platinum Red and Blue
                  #25560    
                Old June 14th, 2013 (7:35 PM).
                BlackWhiteRobin's Avatar
                BlackWhiteRobin BlackWhiteRobin is offline
                   
                  Join Date: Sep 2012
                  Age: 19
                  Gender: Male
                  Nature: Quirky
                  Posts: 537
                  Quote:
                  Originally Posted by gogojjtech View Post
                  Hidesprite and showsprite only work on level scripts, but movesprite and movesprite2 work all the time. Remember that.
                  Actually hidesprite and showsprite can work in normal scripts too.
                  __________________

                    #25561    
                  Old June 14th, 2013 (7:40 PM).
                  karatekid552's Avatar
                  karatekid552 karatekid552 is offline
                  What happens if I push it?....
                     
                    Join Date: Nov 2012
                    Location: Do you really want to know? Really?
                    Gender: Male
                    Nature: Bold
                    Posts: 1,766
                    Quote:
                    Originally Posted by gogojjtech View Post
                    Hidesprite and showsprite only work on level scripts, but movesprite and movesprite2 work all the time. Remember that.
                    I have told you this before, that is NOT true. I use hidesprite in Person Events all the time.

                    CrystalStatic: I have no idea why that would happen. However I can tell you that there is an applymovement movement command that will hide sprites and show sprites just like the hidesprite and showsprite commands do. So, instead of hidesprite, you could have:

                    applymovement 0xYY @hide

                    #org @hide
                    0x60 //0x61 will show, 0x60 will hide
                    0xFE

                    So, see if that works. It may be inefficient, but it is an alternative.
                    __________________

                    Paired with Simba
                      #25562    
                    Old June 15th, 2013 (10:40 AM).
                    ezra_maluku ezra_maluku is offline
                       
                      Join Date: Jul 2012
                      Gender: Male
                      Posts: 4
                      I'm very new to pokemon hacking so i need help

                      I'm hacking pokemon fire red for my own amusment, but what bothers me is that Ghost type attacks are physical, is there anyway to change it into special? and if so, what tool should i be using?

                      I saw in some hack games they had hacked all attacks to match the Fourth generation physical special attack system so i know its possible
                        #25563    
                      Old June 15th, 2013 (12:39 PM).
                      thanethane98's Avatar
                      thanethane98 thanethane98 is offline
                      Self Proclaimed Expert
                         
                        Join Date: Jun 2012
                        Nature: Relaxed
                        Posts: 83
                        Hello. I'm getting a kind of weird error with tiles, and I have absolutely no idea what's causing it. Whenever entering 1 specific map, the tiles around the entrance just become completely messed up. Upon going deeper into the town, where the tiles aren't glitched out, and coming back to the entrance, the tiles are no longer glitched out. It only seems to happen when entering the town from 1 specific entrance. Anybody know what to do to prevent the tiles from glitching out?

                        Here's a screenshot of the issue.
                        Spoiler:
                        __________________
                        Back and ROM hacking again!
                          #25564    
                        Old June 15th, 2013 (1:58 PM).
                        reshilegend's Avatar
                        reshilegend reshilegend is offline
                        Focus.
                           
                          Join Date: Jun 2013
                          Location: Probably not the same place as you
                          Gender: Male
                          Nature: Calm
                          Posts: 265
                          @thanethane98

                          Are you using different tilesets (tileset 2 in AM) for the route and the city? Because sometimes glitches like that can happen when for example the house tiles of the city aren't in your route's tileset 2. Gamefreak usually solves this problem by using gatehouses so that there isn't a direct connection between the 2 maps. You could also move the glitchy tiles in the city a bit up so that you'll only see them when you've entered the city map. The tiles should be loaded properly then.
                          __________________

                            #25565    
                          Old June 15th, 2013 (3:49 PM).
                          karatekid552's Avatar
                          karatekid552 karatekid552 is offline
                          What happens if I push it?....
                             
                            Join Date: Nov 2012
                            Location: Do you really want to know? Really?
                            Gender: Male
                            Nature: Bold
                            Posts: 1,766
                            Quote:
                            Originally Posted by ezra_maluku View Post
                            I'm very new to pokemon hacking so i need help

                            I'm hacking pokemon fire red for my own amusment, but what bothers me is that Ghost type attacks are physical, is there anyway to change it into special? and if so, what tool should i be using?

                            I saw in some hack games they had hacked all attacks to match the Fourth generation physical special attack system so i know its possible
                            Spherical Ice would like to sponsor this message in saying that there is a handy dandy search feature on this forum, in fact, it is right in the title.

                            This question has been asked soooooooooo many times, it isn't funny. There is a patch which will add the physical/special split to your rom. Search for it.
                            __________________

                            Paired with Simba
                              #25566    
                            Old June 15th, 2013 (4:45 PM).
                            thanethane98's Avatar
                            thanethane98 thanethane98 is offline
                            Self Proclaimed Expert
                               
                              Join Date: Jun 2012
                              Nature: Relaxed
                              Posts: 83
                              Quote:
                              Originally Posted by reshilegend View Post
                              @thanethane98

                              Are you using different tilesets (tileset 2 in AM) for the route and the city? Because sometimes glitches like that can happen when for example the house tiles of the city aren't in your route's tileset 2. Gamefreak usually solves this problem by using gatehouses so that there isn't a direct connection between the 2 maps. You could also move the glitchy tiles in the city a bit up so that you'll only see them when you've entered the city map. The tiles should be loaded properly then.
                              Thanks, that should fix it. I can't believe I didn't even consider something like that, it seems so obvious now that you've pointed it out.
                              __________________
                              Back and ROM hacking again!
                                #25567    
                              Old June 15th, 2013 (5:22 PM).
                              GoGoJJTech's Avatar
                              GoGoJJTech GoGoJJTech is offline
                              (☞゚ヮ゚)☞ http://GoGoJJTech.com ☜(゚ヮ゚☜)
                              • Gold Tier
                               
                              Join Date: Nov 2012
                              Location: Earth
                              Age: 18
                              Gender: Female
                              Nature: Jolly
                              Posts: 2,477
                              That's why the DS games contain little bridges or homes in-between maps to stop that glitch, Gamefreak gets away with everything.
                              __________________
                              I believe in Jesus Christ my Savior. If you do too, and aren't scared to admit it, then copy and paste this into your signature.
                              The HGSS Music Patch - The BW/2 Music Patch - ASM: Switch Music Based on Seasons
                              Romhack.me Profile - Pokecommunity Profile - Youtube Channel

                              Support me at my site!
                              Pokémon Platinum Red and Blue
                                #25568    
                              Old June 15th, 2013 (8:01 PM). Edited June 15th, 2013 by Sagiri.
                              Sagiri's Avatar
                              Sagiri Sagiri is offline
                                 
                                Join Date: Mar 2007
                                Age: 23
                                Posts: 732
                                One thing I was curious about - how did JPAN manage to add specials to the game? I know ASM, so I can understand how most of his routines work (at least in a vague way), however I don't understand how he made them compatible with the "special" and "special2" commands in scripting.

                                I'm guessing that there is some table somewhere that has pointers to each special in order, and he just expanded / exploited that table, but I'm not sure. And, even if I'm right, I can't find any information on where such a table would exist (or even if it does).

                                If someone knows anything, I'd appreciate it.

                                EDIT: After doing a little more searching, I realized that he didn't add specials, but instead replaced duplicate, useless, or nonfuctional specials. However, I am still confused as to how he knew what pointers to replace to make his custom routines work with the "special" and "special2" commands.
                                  #25569    
                                Old June 15th, 2013 (11:19 PM).
                                coolking49's Avatar
                                coolking49 coolking49 is offline
                                   
                                  Join Date: Aug 2009
                                  Location: Northfield, MN
                                  Age: 21
                                  Gender: Male
                                  Nature: Adamant
                                  Posts: 36
                                  I'm having a little problem in my romhack, which i think the images attached show

                                  So this is me on a certain map, where this glitch happens.

                                  The problem occurs after I open my bag, or if I battle the one trainer in the room (the guy with the cape).

                                  After you go back to the map, you become a different person. Your guy doesn't move, instead, you become the guy in front of the elevator.

                                  And you can move him, which lasts until you leave the map.

                                  Can anyone tell me how to fix this? There are a couple scripts on the map, but I don't think they are causing the problem. Here is the map before the battle:

                                  where the elevator guy has a normal message script, the old man and your rival disappear after the battle, the guy next to the cases says one thing before the battle and another thing after the battle, and the guy in the cape talks, battles you, a flag is set which causes the people to leave and text to change, and then he says something different after you beat him. This all works fine if I leave the map via the stairs and come back, after the glitch occurs. Any help would be greatly appreciated!
                                  Attached Images
                                  File Type: png glitch p1.PNG‎ (4.2 KB, 6 views) (Save to Dropbox)
                                  File Type: png glitch2.PNG‎ (4.7 KB, 4 views) (Save to Dropbox)
                                  File Type: png glitch3.PNG‎ (4.2 KB, 4 views) (Save to Dropbox)
                                  File Type: png glitch4.PNG‎ (4.6 KB, 4 views) (Save to Dropbox)
                                  File Type: png glitch5.PNG‎ (4.8 KB, 5 views) (Save to Dropbox)
                                    #25570    
                                  Old June 15th, 2013 (11:42 PM).
                                  Cryptonix's Avatar
                                  Cryptonix Cryptonix is offline
                                     
                                    Join Date: Jun 2013
                                    Gender: Male
                                    Posts: 41
                                    Hey. I need a little assistance with a FireRed hack I'm doing.

                                    I'm trying to change the palette of both playable characters' outfits in their introduction sprites, but it doesn't seem to let me import and save the changes I made.

                                    I've kind of just played around with it and tried doing things in a fool-proof way, but that didn't work.

                                    The first method I used was one I found on Zel's tutorial, which was to use the black and white palette of it and replace the right levels, but that didn't work. Ended up all yellow and purple. I then just tried editing the original picture that I found online and importing it, but it wouldn't save the palette. Tried decreasing the depth to 16 bit with Infranview, but that didn't solve the problem.

                                    How would I go about doing this? I didn't use any new colors; I recycled the blue from their other other articles of clothing.

                                    (Can't post the images because I apparently need 15 posts)

                                    If it's of any help, their sprites in unLZ.GBA are 340-341 in 256 Color Mode.
                                      #25571    
                                    Old June 16th, 2013 (12:10 AM).
                                    Akiba's Avatar
                                    Akiba Akiba is offline
                                    • Crystal Tier
                                     
                                    Join Date: Mar 2011
                                    Location: in a gap
                                    Age: 18
                                    Gender: Female
                                    Nature: Brave
                                    Posts: 4,268
                                    Quote:
                                    Originally Posted by Cryptonix View Post
                                    Hey. I need a little assistance with a FireRed hack I'm doing.

                                    I'm trying to change the palette of both playable characters' outfits in their introduction sprites, but it doesn't seem to let me import and save the changes I made.

                                    I've kind of just played around with it and tried doing things in a fool-proof way, but that didn't work.

                                    The first method I used was one I found on Zel's tutorial, which was to use the black and white palette of it and replace the right levels, but that didn't work. Ended up all yellow and purple. I then just tried editing the original picture that I found online and importing it, but it wouldn't save the palette. Tried decreasing the depth to 16 bit with Infranview, but that didn't solve the problem.

                                    How would I go about doing this? I didn't use any new colors; I recycled the blue from their other other articles of clothing.

                                    (Can't post the images because I apparently need 15 posts)

                                    If it's of any help, their sprites in unLZ.GBA are 340-341 in 256 Color Mode.
                                    Sometimes, doing things in a foolproof way never gets things done. Make a copy of your ROM and go wild.

                                    When you insert an image, make sure your check 'Repoint Image Palette' as well, otherwise the new sprite would use the old palette and new sprite.
                                    __________________
                                      #25572    
                                    Old June 16th, 2013 (12:44 AM). Edited June 16th, 2013 by Cryptonix.
                                    Cryptonix's Avatar
                                    Cryptonix Cryptonix is offline
                                       
                                      Join Date: Jun 2013
                                      Gender: Male
                                      Posts: 41
                                      Quote:
                                      Originally Posted by DeltaSalamence View Post
                                      Sometimes, doing things in a foolproof way never gets things done. Make a copy of your ROM and go wild.

                                      When you insert an image, make sure your check 'Repoint Image Palette' as well, otherwise the new sprite would use the old palette and new sprite.
                                      I don't think that worked.

                                      The one thing I can say is that the palette that shows up when you first go to it isn't the original and when you search through all of the palettes, there ISN'T the original. It's all just random palettes, like random greens, purples, yellows, blues. But never the original.

                                      And there's only 67 palettes for them.

                                      So...I just don't know how to do it. I import the image over the default (which is 9, by the way) and it comes out a different palette than I wanted. Even after it accepts the new palette and everything. I don't know what I'm doing.

                                      I so wish I could post pictures so maybe you could get an idea and maybe understand a little better if you haven't already, but stupid PokeCommunity is stupid.
                                        #25573    
                                      Old June 16th, 2013 (12:59 AM).
                                      Akiba's Avatar
                                      Akiba Akiba is offline
                                      • Crystal Tier
                                       
                                      Join Date: Mar 2011
                                      Location: in a gap
                                      Age: 18
                                      Gender: Female
                                      Nature: Brave
                                      Posts: 4,268
                                      Quote:
                                      Originally Posted by Cryptonix View Post
                                      I don't think that worked.

                                      The one thing I can say is that the palette that shows up when you first go to it isn't the original and when you search through all of the palettes, there ISN'T the original. It's all just random palettes, like random greens, purples, yellows, blues. But never the original.

                                      And there's only 67 palettes for them.

                                      So...I just don't know how to do it. I import the image over the default (which is 9, by the way) and it comes out a different palette than I wanted. Even after it accepts the new palette and everything. I don't know what I'm doing.

                                      I so wish I could post pictures so maybe you could get an idea and maybe understand a little better if you haven't already, but stupid PokeCommunity is stupid.
                                      The colors are right, correct? Just allocated to the wrong pixels? If that's the case, you must invert the transparency color in a software such as IrfanView. I believe that DJG has a YouTube video about how to do this. I usually provide links, but I'm on my mobile right now, sorry.
                                      __________________
                                        #25574    
                                      Old June 16th, 2013 (1:10 AM).
                                      Cryptonix's Avatar
                                      Cryptonix Cryptonix is offline
                                         
                                        Join Date: Jun 2013
                                        Gender: Male
                                        Posts: 41
                                        Quote:
                                        Originally Posted by DeltaSalamence View Post
                                        The colors are right, correct? Just allocated to the wrong pixels? If that's the case, you must invert the transparency color in a software such as IrfanView. I believe that DJG has a YouTube video about how to do this. I usually provide links, but I'm on my mobile right now, sorry.
                                        I don't think that's the case. Do you mean random pixels blotted everywhere not even resembling the character? No, that's not it. Or do you mean the right colors, just spread around the character in the incorrect order? No, that's not it either.

                                        It resembles the shape of the character, but it's just the wrong colors. When I import the right picture with the right colors on the 9th palette, which is the first one to show up, and save while checking Export Image, Export Palette, and Automatically Fix Pointers, it doesn't work. It saves perfectly fine over the 9th palette, but I open the game and it's still the wrong palette. Not the same as the 9th, though; it's some random other palette with pinks and stuff.

                                        And if I go to its other default palettes, which there are only 67 of them, the original sprite palette (the one that isn't edited) isn't there.
                                          #25575    
                                        Old June 16th, 2013 (1:13 AM).
                                        DrFuji's Avatar
                                        DrFuji DrFuji is offline
                                        Heiki Hecchara‌‌
                                        • Crystal Tier
                                         
                                        Join Date: Sep 2009
                                        Location: Downia-upside
                                        Age: 24
                                        Gender: Male
                                        Nature: Jolly
                                        Posts: 1,328
                                        Quote:
                                        Originally Posted by coolking49 View Post
                                        I'm having a little problem in my romhack, which i think the images attached show

                                        So this is me on a certain map, where this glitch happens.

                                        The problem occurs after I open my bag, or if I battle the one trainer in the room (the guy with the cape).

                                        After you go back to the map, you become a different person. Your guy doesn't move, instead, you become the guy in front of the elevator.

                                        And you can move him, which lasts until you leave the map.

                                        Can anyone tell me how to fix this? There are a couple scripts on the map, but I don't think they are causing the problem. Here is the map before the battle:

                                        where the elevator guy has a normal message script, the old man and your rival disappear after the battle, the guy next to the cases says one thing before the battle and another thing after the battle, and the guy in the cape talks, battles you, a flag is set which causes the people to leave and text to change, and then he says something different after you beat him. This all works fine if I leave the map via the stairs and come back, after the glitch occurs. Any help would be greatly appreciated!
                                        One or more of the OWs in that map probably have their movement set as 'Look Down'. Changing it to 'No Movement' will most likely fix your problem.
                                        __________________
                                        Closed Thread
                                        Quick Reply

                                        Sponsored Links
                                        Thread Tools

                                        Posting Rules
                                        You may not post new threads
                                        You may not post replies
                                        You may not post attachments
                                        You may not edit your posts

                                        BB code is On
                                        Smilies are On
                                        [IMG] code is On
                                        HTML code is Off

                                        Forum Jump


                                        All times are GMT -8. The time now is 12:11 AM.