ROM Hacking Need a helping hand? You can get help on any ROM Hacking-related problems or questions you have here.

Closed Thread
 
Thread Tools
  #11026    
Old August 16th, 2009 (11:52 AM).
Sunnybeam's Avatar
Sunnybeam Sunnybeam is offline
when the sky is bright
     
    Join Date: Jul 2008
    Age: 22
    Gender: Female
    Nature: Docile
    Posts: 544
    -sighs- Right, so, I'm inserting tiles into an Emerald ROM from scratch. I deleted the main tileset and am putting in each block and changing the pallettes myself. However, pretty early on, I realized I had a big problem - animated tiles.

    I found a tutorial here on PC for changing the grass animation, so I think I'm covered there. But the only tutorial for changing the water animation is for FR, not Emerald, requires the use of TileMolester, which refuses to run on my computer, and involves editing tiles that already exist in the game, whereas I am working from a blank slate as far as tiles go.

    Does anyone know how to create an animated tile from scratch? If not, does anyone have any advice for another way of getting around this problem?

    Help is greatly, greatly appreciated.
    __________________
    My fanfiction: Rune of Water


    Little sister of Bay
    Twin of SailorShadow
    Devoted underling of Midnight Jasper

    Relevant Advertising!

      #11027    
    Old August 16th, 2009 (12:05 PM). Edited August 16th, 2009 by Lukeyjohnno.
    Lukeyjohnno's Avatar
    Lukeyjohnno Lukeyjohnno is offline
    Hacker-In-Training ;)
       
      Join Date: Aug 2007
      Gender:
      Nature: Modest
      Posts: 76
      Ugh. I'm trying to do some coding in XSE, and it's starting to hack me off. (HAHA GET IT? HACK? *cricket noises*)

      But yeah, here's the code:

      Spoiler:
      #dynamic 0x800A71

      #ORG @start
      checkflag 0x828
      if 0x1 goto @done
      setflag 0x828
      msgbox @begin 0x6
      applymovement 0xFF @playermove
      pause 0x50
      msgbox @message 0x6
      fanfare 0x13E
      msgbox @recieved 0x6
      waitfanfare
      givepokemon 0xFC 0x5 0x8B 0x0 0x0 0x0
      release
      end

      #ORG @begin
      = [red_fr][PLAYER], come here please!

      #ORG @done
      release
      end

      #ORG @playermove
      #raw 0x11
      #raw 0x11
      #raw 0x11
      #raw 0x11

      #ORG @message
      = [red_fr]Hello [PLAYER].\pI have your POKéMON here, I have\nnever seen a POKéMON like this one\lbefore... It must be very rare!\lWell here it is, take care of it.

      #ORG @recieved
      = [black_fr][PLAYER] recieved RIOLU!


      Everything goes fine. But when the code finishes, I can't move the player, he is frozen in one spot. I can bring up the help menu using L or R but that is it. I don't understand why it is doing this :\
      __________________
      Banner Created By Me

      Hacks I Support
      Spoiler:
      My Hack

        #11028    
      Old August 16th, 2009 (12:54 PM). Edited August 16th, 2009 by uncivilyoshi.
      uncivilyoshi uncivilyoshi is offline
         
        Join Date: Aug 2009
        Posts: 5
        Quick question, When i try to evolve my Chickorita (Fire red version), All that happens is the evolution stops. Is it because there is no national dex? I was wondering how i can fix this, So i can allow Chickorita and its evolutions to evolve. Thank you. I know this is a pretty stupid question, but it just doesn't allow the evolution.
          #11029    
        Old August 16th, 2009 (2:22 PM).
        NarutoActor's Avatar
        NarutoActor NarutoActor is offline
        The rocks cry out to me
        • Silver Tier
         
        Join Date: Jan 2009
        Location: Brooklyn/Marlboro
        Age: 23
        Gender: Female
        Nature: Bashful
        Posts: 1,979
        Quote:
        Originally Posted by uncivilyoshi View Post
        Quick question, When i try to evolve my Chickorita (Fire red version), All that happens is the evolution stops. Is it because there is no national dex? I was wondering how i can fix this, So i can allow Chickorita and its evolutions to evolve. Thank you. I know this is a pretty stupid question, but it just doesn't allow the evolution.
        haa this question has been asked already not that reasonly and I awsened it but I will do it again next time serch first edit oks script under FR_POKEDEX add NA_POKEDEX under that and complie it :D hope that helps
        __________________
        ~There are those people who understand hex, F the rest
          #11030    
        Old August 16th, 2009 (2:45 PM). Edited August 16th, 2009 by uncivilyoshi.
        uncivilyoshi uncivilyoshi is offline
           
          Join Date: Aug 2009
          Posts: 5
          Quote:
          Originally Posted by narutoactor View Post
          haa this question has been asked already not that reasonly and I awsened it but I will do it again next time serch first edit oks script under FR_POKEDEX add NA_POKEDEX under that and complie it :D hope that helps
          Im still a bit confused, im not sure where i can find that script, im searching for it, but no luck.
            #11031    
          Old August 16th, 2009 (4:48 PM).
          NarutoActor's Avatar
          NarutoActor NarutoActor is offline
          The rocks cry out to me
          • Silver Tier
           
          Join Date: Jan 2009
          Location: Brooklyn/Marlboro
          Age: 23
          Gender: Female
          Nature: Bashful
          Posts: 1,979
          like I said in the PM message send me the script and I will show you and FR_POKEDEX is pksv line not xse :D
          __________________
          ~There are those people who understand hex, F the rest
            #11032    
          Old August 16th, 2009 (4:54 PM).
          siper x's Avatar
          siper x siper x is offline
          I'm Russia, Fear Russia
             
            Join Date: Jul 2009
            Age: 21
            Gender: Male
            Nature: Lonely
            Posts: 376
            in xse how do you make give pokemon scripts?
            __________________
            Never wish for death, but life. If you die, who will protect those precious to you?

            Blood brother to Kroso
              #11033    
            Old August 16th, 2009 (5:23 PM).
            sasquatchd00d's Avatar
            sasquatchd00d sasquatchd00d is offline
            welcoming a clean head.
               
              Join Date: Nov 2008
              Location: barracuda, capital of the world
              Age: 25
              Nature: Relaxed
              Posts: 265
              Quote:
              Originally Posted by Sunnybeam View Post
              -sighs- Right, so, I'm inserting tiles into an Emerald ROM from scratch. I deleted the main tileset and am putting in each block and changing the pallettes myself. However, pretty early on, I realized I had a big problem - animated tiles.

              I found a tutorial here on PC for changing the grass animation, so I think I'm covered there. But the only tutorial for changing the water animation is for FR, not Emerald, requires the use of TileMolester, which refuses to run on my computer, and involves editing tiles that already exist in the game, whereas I am working from a blank slate as far as tiles go.

              Does anyone know how to create an animated tile from scratch? If not, does anyone have any advice for another way of getting around this problem?

              Help is greatly, greatly appreciated.
              You really should have just avoided deleting everything. You should only just replace tiles or remove tiles that you won't be using.
              __________________
              [ [???="Not so good artwork. If you can even call it that."]deviantART[/???] | [???="No thread yet. Maybe eventually."]Pokémon Apollo[/???] | [???="SkythurBathandBeyond151"]Pair[/???] ]
                #11034    
              Old August 16th, 2009 (5:28 PM).
              BlitŻ's Avatar
              BlitŻ BlitŻ is offline
              guahh my dog is so cute
              • Crystal Tier
               
              Join Date: Feb 2009
              Location: Bay Area, Califronia.
              Age: 22
              Gender: Male
              Nature: Jolly
              Posts: 472
              The problem with my rom is that with level scripts

              Today I've inserted about 4 level scripts in, and when I tried to insert the 4th it displayed the same offset anf flag number as the previous one i inserted.

              Could this be happening becuase I inserted too many level scripts in my rom? or because Of some other unexplained reason?

              btw it also displayed the same unhighlited script offset tab as in the previous script I did. And also when I replace the data in one of the maps, the same replaced data is on the other map.

              any help is appreciated
              __________________
                #11035    
              Old August 16th, 2009 (5:29 PM).
              NarutoActor's Avatar
              NarutoActor NarutoActor is offline
              The rocks cry out to me
              • Silver Tier
               
              Join Date: Jan 2009
              Location: Brooklyn/Marlboro
              Age: 23
              Gender: Female
              Nature: Bashful
              Posts: 1,979
              Quote:
              Originally Posted by siper x View Post
              in xse how do you make give pokemon scripts?
              well i anm not a 100% sure for I am used to pokescript it works the same tho givepokemon(this line might be slightly diferent) 0x(pokemon in hex) 0x(pokemons level) 0x(item) rember everything is in hex not dex
              __________________
              ~There are those people who understand hex, F the rest
                #11036    
              Old August 16th, 2009 (6:25 PM).
              BlitŻ's Avatar
              BlitŻ BlitŻ is offline
              guahh my dog is so cute
              • Crystal Tier
               
              Join Date: Feb 2009
              Location: Bay Area, Califronia.
              Age: 22
              Gender: Male
              Nature: Jolly
              Posts: 472
              Quote:
              Originally Posted by Lukeyjohnno View Post
              Ugh. I'm trying to do some coding in XSE, and it's starting to hack me off. (HAHA GET IT? HACK? *cricket noises*)

              But yeah, here's the code:

              Spoiler:
              #dynamic 0x800A71

              #ORG @start
              checkflag 0x828
              if 0x1 goto @done
              setflag 0x828
              msgbox @begin 0x6
              applymovement 0xFF @playermove
              pause 0x50
              msgbox @message 0x6
              fanfare 0x13E
              msgbox @recieved 0x6
              waitfanfare
              givepokemon 0xFC 0x5 0x8B 0x0 0x0 0x0
              release
              end

              #ORG @begin
              = [red_fr][PLAYER], come here please!

              #ORG @done
              release
              end

              #ORG @playermove
              #raw 0x11
              #raw 0x11
              #raw 0x11
              #raw 0x11

              #ORG @message
              = [red_fr]Hello [PLAYER].\pI have your POKéMON here, I have\nnever seen a POKéMON like this one\lbefore... It must be very rare!\lWell here it is, take care of it.

              #ORG @recieved
              = [black_fr][PLAYER] recieved RIOLU!


              Everything goes fine. But when the code finishes, I can't move the player, he is frozen in one spot. I can bring up the help menu using L or R but that is it. I don't understand why it is doing this :\

              You forgot a 0xFE under #org @playermove...haha, I laughed at your joke
              __________________
                #11037    
              Old August 16th, 2009 (7:21 PM).
              IceSage's Avatar
              IceSage IceSage is offline
              Sage of Ice
              • Silver Tier
               
              Join Date: Jul 2007
              Location: Boston, MA
              Age: 32
              Nature: Modest
              Posts: 241
              Forgotten Memory,

              Thank you for the information on the warping information. It was very helpful and I was able to achieve what I was trying to do.

              I'm still having a horrible time trying to change the title screen. I keep thinking I do it right but it always gets extremely messed up.

              Perhaps I'll make a video on what I'm doing and you can tell me what I did wrong. The guide you linked didn't help me, and I think I've seen it before.

              Usually most of the time, the end product ends up being what I'm replacing totally not there anymore, with a bunch of jibberish on the ENTIRE screen. I've been following directions online, and from the guide added into the version of Cyclone I have.

              Argh, I wish this was like back in the day, with Tlayer...
                #11038    
              Old August 17th, 2009 (12:54 AM).
              Thrace's Avatar
              Thrace Thrace is offline
              @tion
              • Gold Tier
               
              Join Date: Jun 2007
              Age: 26
              Gender: Male
              Posts: 1,048
              Quote:
              Originally Posted by DiSCIclaimer View Post
              Ahh.... having problems with my overworld...
              First evrythin looks oK... http://i31.tinypic.com/25hdg5u.png
              Then when i come out of that truck my overworld turns transparent.... http://i27.tinypic.com/25zguf9.png
              Then when i come into the house the same thing... http://i27.tinypic.com/2ivzfyx.png
              When i come into the room evrythin turns normall.... :( http://i31.tinypic.com/n7md.png
              Then in the beggining of the Proffesor script wer he gets chased by that dog my sprite turns into another couler again... < http://i29.tinypic.com/dg3rko.png

              1. Yes i tried changin the coulers..... dont work<
              2. Dis happens only to the boy sprite... caz probally i didnt change the girls sprite yet...
              3. Tried changing the trucks palletes

              Plz help.... tried lots of things but it jus dont work..
              Your best bet would be to restart on a new rom.

              Quote:
              Originally Posted by Sunnybeam View Post
              -sighs- Right, so, I'm inserting tiles into an Emerald ROM from scratch. I deleted the main tileset and am putting in each block and changing the pallettes myself. However, pretty early on, I realized I had a big problem - animated tiles.

              I found a tutorial here on PC for changing the grass animation, so I think I'm covered there. But the only tutorial for changing the water animation is for FR, not Emerald, requires the use of TileMolester, which refuses to run on my computer, and involves editing tiles that already exist in the game, whereas I am working from a blank slate as far as tiles go.

              Does anyone know how to create an animated tile from scratch? If not, does anyone have any advice for another way of getting around this problem?

              Help is greatly, greatly appreciated.
              No ones figured out how animation works yet afaik. You'll have to start again and make sure you place your new sea tiles over the old ones.

              Quote:
              Originally Posted by Fan King View Post
              The problem with my rom is that with level scripts

              Today I've inserted about 4 level scripts in, and when I tried to insert the 4th it displayed the same offset anf flag number as the previous one i inserted.

              Could this be happening becuase I inserted too many level scripts in my rom? or because Of some other unexplained reason?

              btw it also displayed the same unhighlited script offset tab as in the previous script I did. And also when I replace the data in one of the maps, the same replaced data is on the other map.

              any help is appreciated ^^
              Its possible I suppose. Its hard to tell where you might have gone wrong by your description. Remember: you can always combine two scripts by separating them with checkflags.

              Thats usually caused by the map data overflowing into another map's data. You'll need to repoint the one thats overflowing (do both just to be thorough).

              Quote:
              Originally Posted by IceSage View Post
              Forgotten Memory,

              Thank you for the information on the warping information. It was very helpful and I was able to achieve what I was trying to do.

              I'm still having a horrible time trying to change the title screen. I keep thinking I do it right but it always gets extremely messed up.

              Perhaps I'll make a video on what I'm doing and you can tell me what I did wrong. The guide you linked didn't help me, and I think I've seen it before.

              Usually most of the time, the end product ends up being what I'm replacing totally not there anymore, with a bunch of jibberish on the ENTIRE screen. I've been following directions online, and from the guide added into the version of Cyclone I have.

              Argh, I wish this was like back in the day, with Tlayer...
              It sounds like you might be forgetting to repoint the tilemap data. Use NTME (*sigh* why are people still using Cyclone?) theres a video in the thread that shows you how to edit title screens that should help.
              __________________
                #11039    
              Old August 17th, 2009 (5:10 AM).
              BlitŻ's Avatar
              BlitŻ BlitŻ is offline
              guahh my dog is so cute
              • Crystal Tier
               
              Join Date: Feb 2009
              Location: Bay Area, Califronia.
              Age: 22
              Gender: Male
              Nature: Jolly
              Posts: 472
              so thrace which do I repoint?, The map script offset or the map footer offset or a dfferent offset in the advance header menu
              __________________
                #11040    
              Old August 17th, 2009 (5:15 AM).
              Curt_09's Avatar
              Curt_09 Curt_09 is offline
              Also known as Chozo
                 
                Join Date: Feb 2009
                Location: Oklahoma
                Age: 26
                Gender: Male
                Posts: 500
                I've scrounged around for anything on this, but haven't had much luck. I followed haefele's tutorial on inserting the world map, and it worked like a charm. Except for two things...

                The colors of the town squares are wrong, and the little location buttons from the original FireRed are still there.
                Does anybody know the RGB values of the correct shades of grey to use for the towns to where they will use the right colors in game?
                Does anybody know why those old pieces are still showing up on the map?
                __________________
                Old hacks I liked back in the day:



                  #11041    
                Old August 17th, 2009 (7:18 AM).
                NarutoActor's Avatar
                NarutoActor NarutoActor is offline
                The rocks cry out to me
                • Silver Tier
                 
                Join Date: Jan 2009
                Location: Brooklyn/Marlboro
                Age: 23
                Gender: Female
                Nature: Bashful
                Posts: 1,979
                Quote:
                Originally Posted by Curt_09 View Post
                I've scrounged around for anything on this, but haven't had much luck. I followed haefele's tutorial on inserting the world map, and it worked like a charm. Except for two things...

                The colors of the town squares are wrong, and the little location buttons from the original FireRed are still there.
                Does anybody know the RGB values of the correct shades of grey to use for the towns to where they will use the right colors in game?
                Does anybody know why those old pieces are still showing up on the map?
                the firered titles are an easy fix you can use advance map
                __________________
                ~There are those people who understand hex, F the rest
                  #11042    
                Old August 17th, 2009 (7:39 AM).
                Curt_09's Avatar
                Curt_09 Curt_09 is offline
                Also known as Chozo
                   
                  Join Date: Feb 2009
                  Location: Oklahoma
                  Age: 26
                  Gender: Male
                  Posts: 500
                  Quote:
                  Originally Posted by narutoactor View Post
                  the firered titles are an easy fix you can use advance map
                  Care to elaborate on that? It doesn't do me much good.
                  I've looked at it in advance map and changed the routes, but it didn't seem to do anything.
                  __________________
                  Old hacks I liked back in the day:



                    #11043    
                  Old August 17th, 2009 (8:16 AM).
                  NarutoActor's Avatar
                  NarutoActor NarutoActor is offline
                  The rocks cry out to me
                  • Silver Tier
                   
                  Join Date: Jan 2009
                  Location: Brooklyn/Marlboro
                  Age: 23
                  Gender: Female
                  Nature: Bashful
                  Posts: 1,979
                  mmm rele I thought that would fix that problem I am having problems inserting my world map too So I put It off to I become a better hacker Sorry :C
                  __________________
                  ~There are those people who understand hex, F the rest
                    #11044    
                  Old August 17th, 2009 (8:20 AM).
                  Diegoisawesome's Avatar
                  Diegoisawesome Diegoisawesome is offline
                  Oh god the bees
                  • Silver Tier
                   
                  Join Date: Dec 2007
                  Location: :noitacoL
                  Age: 20
                  Gender: Male
                  Nature: Naive
                  Posts: 1,035
                  Quote:
                  Originally Posted by diegoisawesome View Post
                  I have the same tilemap being used for two of my world maps. For some reason, on the fourth world map (which is #3 in the programming), nine tiles near the bottom-right corner keep getting replaced with tile #3, while on the other, it works just fine.

                  Can anyone help?
                  Yet another repost. Can anyone help?
                  __________________


                  My other resources:
                  My Website
                  diegoisawesome's MEGA-HUGE XSE Scripting Tutorial
                  diegoisawesome's Miscellaneous Finds
                  The Ruins of Alph Puzzles
                  Diego's Miscellaneous Patches
                  GBA Intro Manager
                  The Secret Sauce: Triple-Layer Tiles
                    #11045    
                  Old August 17th, 2009 (9:19 AM).
                  IceSage's Avatar
                  IceSage IceSage is offline
                  Sage of Ice
                  • Silver Tier
                   
                  Join Date: Jul 2007
                  Location: Boston, MA
                  Age: 32
                  Nature: Modest
                  Posts: 241
                  Quote:
                  Originally Posted by Thrace View Post
                  It sounds like you might be forgetting to repoint the tilemap data. Use NTME (*sigh* why are people still using Cyclone?) theres a video in the thread that shows you how to edit title screens that should help.
                  I meant I used the guide that was included with Cyclone, not Cyclone itself. Although, NTME is just about the same, only it's a bit easier to use. Also, neither program allows for selecting multiple tiles, so they're just about even on the playing field for me anyway.

                  Also, which thread are you referring to that has the video?

                  Argh. I'll figure it out... someday... Someday..
                    #11046    
                  Old August 17th, 2009 (9:32 AM).
                  Diegoisawesome's Avatar
                  Diegoisawesome Diegoisawesome is offline
                  Oh god the bees
                  • Silver Tier
                   
                  Join Date: Dec 2007
                  Location: :noitacoL
                  Age: 20
                  Gender: Male
                  Nature: Naive
                  Posts: 1,035
                  Quote:
                  Originally Posted by Curt_09 View Post
                  I've scrounged around for anything on this, but haven't had much luck. I followed haefele's tutorial on inserting the world map, and it worked like a charm. Except for two things...

                  The colors of the town squares are wrong, and the little location buttons from the original FireRed are still there.
                  Does anybody know the RGB values of the correct shades of grey to use for the towns to where they will use the right colors in game?
                  Does anybody know why those old pieces are still showing up on the map?
                  When putting in the town squares, they must be in Pal 1, not Pal 0. Choose Pal 1 when mapping the squares.
                  __________________


                  My other resources:
                  My Website
                  diegoisawesome's MEGA-HUGE XSE Scripting Tutorial
                  diegoisawesome's Miscellaneous Finds
                  The Ruins of Alph Puzzles
                  Diego's Miscellaneous Patches
                  GBA Intro Manager
                  The Secret Sauce: Triple-Layer Tiles
                    #11047    
                  Old August 17th, 2009 (9:43 AM).
                  siper x's Avatar
                  siper x siper x is offline
                  I'm Russia, Fear Russia
                     
                    Join Date: Jul 2009
                    Age: 21
                    Gender: Male
                    Nature: Lonely
                    Posts: 376
                    FIRE RED QUESTIONS

                    how do you insert town maps?

                    I keep trying to make signpost items, but it doesn't work.
                    in my hack it is on a shrub. can you put 1 there?

                    how do you make it so you don't have to go to the 2nd city to get oak's parecel, but can get it in pallet town?
                    __________________
                    Never wish for death, but life. If you die, who will protect those precious to you?

                    Blood brother to Kroso
                      #11048    
                    Old August 17th, 2009 (11:43 AM).
                    Curt_09's Avatar
                    Curt_09 Curt_09 is offline
                    Also known as Chozo
                       
                      Join Date: Feb 2009
                      Location: Oklahoma
                      Age: 26
                      Gender: Male
                      Posts: 500
                      Thanks Diego, that worked. Really, thanks a lot.
                      Narutoactor I went back and tried it again and it worked this time.
                      You guys just saved me hours of fiddling around on my own.
                      __________________
                      Old hacks I liked back in the day:



                        #11049    
                      Old August 17th, 2009 (4:26 PM). Edited August 17th, 2009 by siper x.
                      siper x's Avatar
                      siper x siper x is offline
                      I'm Russia, Fear Russia
                         
                        Join Date: Jul 2009
                        Age: 21
                        Gender: Male
                        Nature: Lonely
                        Posts: 376
                        what is the xse script for:

                        geting a cubone lv 15 with pokerus,

                        and an eevee lv 7 with a pokedex, and 5 pokeballs?

                        Thanks in advance, and please answer my other questions.

                        if theese questions get answered i can realese games, in progressing hacks, or finish the one in the scapbox.

                        in advance map (ruby)
                        how can you make a tree headbuttable?
                        what behavior byte do you use?
                        __________________
                        Never wish for death, but life. If you die, who will protect those precious to you?

                        Blood brother to Kroso
                          #11050    
                        Old August 17th, 2009 (8:05 PM).
                        3dd13's Avatar
                        3dd13 3dd13 is offline
                        Leader of the Fallen
                           
                          Join Date: Oct 2008
                          Location: Alabama! The Heart of Hell!
                          Age: 25
                          Gender: Male
                          Nature: Lonely
                          Posts: 96
                          Quote:
                          Originally Posted by Thrace View Post
                          Try repointing the data of both tilemaps.


                          What do you mean its corrupt? You'll need to download the .NET framework to get it to work.


                          1) Yes, theres a few tutorials around that tell you how to do it.
                          2) Yes, but you'll probably only be able to edit the graphics and not the actual layout.
                          3) XSE and pksvui allow you to do this.
                          i have installed all the files nessecary to fun yape (.net 2.0, the vb6 runtime files) and it still doesnt work... i get an 0xc000007b error. i dont know why...
                          __________________
                          Closed Thread
                          Quick Reply

                          Sponsored Links
                          Thread Tools

                          Posting Rules
                          You may not post new threads
                          You may not post replies
                          You may not post attachments
                          You may not edit your posts

                          BB code is On
                          Smilies are On
                          [IMG] code is On
                          HTML code is Off

                          Forum Jump


                          All times are GMT -8. The time now is 2:04 PM.