View Full Version : External Hard Drive problem

May 24th, 2010, 2:42 PM
I bought an external hard drive yesterday. I was playing Portal (which I had saved on it) and I accidentally pulled on the cord and the hard drive fell about 2 and a half feet. The outside casing came off, but I was able to get it back on. Now when I try to plug it back in, my laptop isn't even noticing it's there. There seems to be no internal damage. Is there something I can look up? Should I take it back to Staples? Any help is appreciated. Thank you very much.

May 24th, 2010, 3:45 PM
You may have shattered one of the platters, or the read-write head on the actual hard drive. It'd help to know if it's making any kind of strange noises. Also have you tested it in other computers? And have you tried to connect it more than once? Or even just let it sit for 10 minutes to give it a chance to try to fix itself (this last one sorta happened to me a few weeks ago)? And are you sure it wasn't

If it's a hardware problem, and you got a warranty with it, I'd exercise that and see where that gets you. I don't think that'd be very far, though, because they're likely going to pin this on you. Were you using it for anything other than save files for Portal? Or did I misread that and the external drive was where you were storing the entire game?

May 24th, 2010, 4:07 PM
The entire Portal Game, the StarCraft II beta, Photoshop CS3, and some music were on the hard drive. I sent an email to their support team, and I hopefully should get a reply by tomorrow, Thursday the latest.

I tried all of your methods, except for trying another computer, only because we have one computer :(

May 24th, 2010, 5:34 PM
Have you tried restarting the Computer that you use it on? I have problems that if I use Safely Remove Hardware on my Computer when using a MicroSD adapter and a MicroSD card, my Computer won't read any of the drives, and I have to restart the Computer. Also, as Donavannj said, it could be something to do with the read/write.

May 24th, 2010, 5:41 PM
I'll try restarting, and see if that works.

On an unrelated note, your picture is awesome. :D