• Our software update is now concluded. You will need to reset your password to log in. In order to do this, you will have to click "Log in" in the top right corner and then "Forgot your password?".
  • Welcome to PokéCommunity! Register now and join one of the best fan communities on the 'net to talk Pokémon and more! We are not affiliated with The Pokémon Company or Nintendo.

My attempt to get Pokemon Platinum


An "Original" PC Supporter
  • 7,501
    So I decided I would go to JB Hi-Fi, which is about 15 minutes walking distance, to get Platinum. There's a trade-in deal where you get the game free if you trade in 2 other DS games. I was going to trade in Yu-Gi-Oh! World Championships 2007 and More Brain Training.

    I got dressed wearing a t-shirt and jeans. I sort of jogged there in excitement. I've actually played through the whole game using the US ROM that was leaked ages ago. When I got to JB Hi-Fi, I went to the counter and requested the deal. She told me I needed the game cases and manuals. So I ran home because I forgot to bring them with me. You'd think I learnt my lesson after this incident but noooooooo; I'm an idiot. >.>

    By the time I got home, I was sweating like a pig so I ate an ice block and changed from my jeans to shorts. I actually didn't have the game case for More Brain Training (because of this) so I had to sacrifice another game for it instead. I set out once again. This time I decided I would take the bus. I waited around 10 minutes for the bus. I didn't think it would actually take that long.

    When I got there, I went to the counter once again. The woman recognised me right away and asked "trade-in?" I answered back and she requested for the staff who did the stuff for trade-ins. The guy comes to me and points out that I need to be over 18.


    So I ran home because I'm so pissed and don't want to waste more money for the bus far. (90c isn't much but meh). I arrive home and I find that the lift is stuck at level 2. I assumed some idiot's kid was playing a joke so I started hammering at the lift door thingy with my fists. Nothing happens after 5 minutes. Then some guy came down and told me it wasn't working so I had to call my sister down to let me in with the keys since the fire stairs require keys to get access to.