Thread: Development: Move Resource Thread
View Single Post
Old June 16th, 2013 (4:56 PM).
MrDollSteak's Avatar
MrDollSteak MrDollSteak is offline
Formerly known as 11bayerf1
    Join Date: Dec 2008
    Location: Hong Kong
    Age: 22
    Gender: Male
    Posts: 804
    Originally Posted by Pink Parka Girl View Post
    I tried porting this Dragon Pulse to Ruby, and the game resets when the move is used without even attempting to play any of the animation. To try and check where the error might have been coming from, I tried using the code exactly as you'd typed it (adding in pointers in place of all the xx yy zz's, of course) in Fire Red and while it didn't reset, it played a sound briefly and then froze. D: Is this script simply broken or am I doing something wrong? For reference, the offsets I'm using in both Ruby and Fire Red are 950D6C (script start), 950E10 for XX YY ZZ, and 950E86 for XX2 YY2 ZZ2. I tried different offsets in both games to make sure this wasn't the problem and the attack STILL does not work in either, and I'm at a loss as to what I could be doing wrong. Would you have any suggestions?
    Just to make sure are you typing the pointers in reverse? From what I can see, the script seems to be ok, and I believe Dreamengine managed to use it as well.

    Just in case, a small example would be that 950E10 would be written as 10 0E 95 in the script.

    If it is still working I'll try setting it up myself in a new rom to see if there is a problem with it.
    Reply With Quote